DKIM on Microsoft Server

Good morning, My email server is on microsoft, domain on godaddy and DNS(https) on Cloudflare. Gmail and yahoo and many others are enforcing DKIM authentication. In order to do it when I go to my microsoft DKIM setting page and click on my domain, DKIM shows as disabled. If I click on enable , it gives me an error message saying "Microsoft.Exchange.Management.Tasks.ValidationException|CNAME record does not exist for this config.
Please publish the following two CNAME records first. "
Even after I add those CNAMEs to cloudflare, microsoft still shows the same error message. What can be done to solve this?

Make sure the CNAME entry is :grey:.

What does it mean? These are my settings

That it needs to be unproxied.

When I unproxy it , it shows me this message " This record exposes the IP address used in the A record on my website. Enable the proxy status to protect your origin server. "

As already mentioned, you only need to unproxy the CNAME entry.


Does it mean this?

That’s :grey:, right?

Thanks so much for the inputs. Microsoft is still showing that its not updated. What can be done?

What’s the actual hostname?

I am not sure

Just post a screenshot where you do not censor things.

1 Like

And the CNAME entries are exactly what Microsoft told you to configure?

Yeah, the configuration won’t be right.

But you do have a security issue on your server and no valid certificate. You need to fix this before we can continue with anything else.

This was the message from microsoft

Understood, but as mentioned you need to fix SSL on your server first.

my website still shows secure, what needs to be fixed and how do we do it?

That’s unfortunately not correct, as the server itself is not secure. Pause Cloudflare and contact your host to get the server configured for SSL.

Once your site loads fine on HTTPS, you can unpause Cloudflare again and we can address the other configuration.

My site is loading on https right now. I checked on another browser

It is not

[REDACTED]

As mentioned, pause Cloudflare and contact your host

1 Like