DKIM check throws permerror

Hi, I believe I have DKIM set up on my server, because it works for a different domain not hosted through Cloudflare. Using the same server with Cloudflare DNS I am getting DKIM permerror when I run validation.

The domain is

Here is what I am using for default._domainkey:

I’ve tried a few permutations and I always seem to get a permerror. What am I doing wrong?

My brain feels mushy now, but Dmarcian agrees something is broken. EDIT: Sorry, I goofed on the selector. Fixed the link:

Can you post a screenshot of that DNS record in the Cloudflare dashboard?

Ok…it looks like it needs a ; at the end. Give that a try.

EDIT…that might not be it.

Next EDIT: I’m no DKIM expert, but my records have spaces after each ;
I also don’t have h=sha256
And I usually have semicolons at the very end.

1 Like

Like this?

I re-ran the Dmarcian test from my earlier link and it likes it. Next step would to test it:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.