Discourse Raspberry Pi 4 Help

So I’ve been trying to setup my Discourse installation for the past few days and honestly it’s been one of the biggest headaches I’ve ever had, from Ubuntu and the Raspberry Pi 4 Model B not being 100% compatible and then costing me 2 SD Cards in which I couldn’t fix.
However I did get it to work and it was all fine, I was ready to actually start work on it. But I wanted to set it up properly with the Tunnel because I want to host websites along side it but on different devices.

So I followed all the steps needed to make a new tunnel and install Cloudflared via the CLI and other than needing to change a few things it seems fine until I try running it as a service, it doesn’t seem to enjoy that part.

These are the errors I get:

failed to sufficiently increase receive buffer size (was: 208 kiB, wanted: 2048 kiB, got: 416 kiB). See https://github.com/lucas-clemente/quic-go/wiki/UDP-Receive-Buffer-Size for details.
ERR Failed to serve quic connection error="Unauthorized: Failed to get tunnel" connIndex=0
ERR Register tunnel error from the server side error="Unauthorized: Failed to get tunnel" connIndex=0
INF Retrying connection in up to 2s seconds connIndex=0
cloudflared.service: Main process exited, code=exited, status=1/FAILURE

I know it’s more authorization but I copied the config.yml from:
/home/dev/.cloudflared/config.yml
to:
usr/local/etc/.cloudflared/config.yml
So I’m unsure what is going on here honestly.

Thanks in advance,
~Blood

I followed the guides I was provided being:
https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/install-and-setup/tunnel-guide/#connect-a-network

So I’ve reinstalled and that seemed to fix my issue, however I am now having another issue. More information can be found on my original post. :slight_smile:

~Blood