Discord link preview not shown when https is used

Hi!

Domain: https://jazper.dk

I have had my site up for a while, and wanted to make it possible to see a site preview on Discord, the problem is, that it only show when using HTTP and not HTTPS
Capture
The A record is Proxied through cloudflare. Is there anything that could be blocking this?
The scrape shield settings looks like this:
Email Address Obfuscation: On
Server-side Excludes: On
Hotlink Protection: Off

I have tried turning them all off, but nothing happened. Any ideas?

You should be able to see something in Firewall events if Cloudflare blocks something.

Yea i checked but it’s empty

I am not 100% sure, but just like Viber, Facebook, LinkedIn, Twitter has … don’t you need some OpenGraph meta tags for that (a part of SEO)?

Make sure to have at your Website:

    <html dir="ltr" lang="en" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
    <head>
         ...
    <meta property="og:title" content='YOUR_WEBPAGE_TITLE'>
    <meta property="og:site_name" content='WEBSITE_NAME'>
    <meta property="og:url" content="YOUR_WEBPAGE_URL">
    <meta property="og:description" content='YOUR_WEBPAGE_DESCRIPTION'>
    <meta property="og:image" content="YOUR_WEBPAGE_IMAGE_URL">
    <meta property="og:image:secure_url" content="YOUR_WEBPAGE_IMAGE_URL">
    <meta property="og:image:type" content="image/jpeg"> <!-- recommend type -->
    <meta property="og:image:alt" content='YOUR_WEBPAGE_DESC_OR_ALT_OF_IMAGE'>
    <meta property="og:image:width" content="1200"> <!-- recommend size -->
    <meta property="og:image:height" content="675"> <!-- recommend size -->
    <meta property="og:type" content="website">
    <meta property="og:locale" content="en_US">
    </head>
         ...

I have tried using open graph, but same thing happens

It is likely that Discord has cached an older version of your website, add OpenGraph tags and then wait a few hours

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.