Disabling IPV6

I’ve disabled Ipv6 in Zone Settings using API. But I still get requests from Ipv6 address.
I also confirmed that Ipv6 is off using API.
cloudflare-ipv6

Can someone help me to understand why is this happening?

Domain?

larvelfaucet(dot)com

Well, there are no IPv6 records for your domain - DNS Checker - DNS Check Propagation Tool

So, clients should not connect via IPv6, however, do you have any AAAA records configured on Cloudflare? If so, Cloudflare may still connect via IPv6 to your server.

Also, did you make sure your server is configured for cloudflare.com/ips and are you rewriting IP addresses?

I don’t have any AAAA records.
And I’m rewriting Remote Address in my Apache config to take HTTP_CF_CONNECTING_IP header.

How did you establish that you are getting IPv6 addresses?

I log all IP address in my DB. I came across a IPv6 addresses in DB for past few days.
Haven’t checked beyond that period.

What about the firewall issue I mentioned?

As mentioned, you should make sure only Cloudflare can connect - https://developers.cloudflare.com/fundamentals/get-started/setup/allow-cloudflare-ip-addresses/

Otherwise, your server may be accessible via IPv6 and these requests may not even go via the proxies.

On Cloudflare’s, there’s no IPv6 address, however if someone still has the proxies’ AAAA records cached, they may be still connecting via IPv6. Enable Pseudo IPv4 in that case, to receive IPv4 addresses for IPv6 ones.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.