Disabling Cloudflare brings up 404 errors


#1

Only just recently noticed this. I know the pages are there since updating and adding new ones causes no problems in being seen.

But for moments the other day and today, when I deactivated Cloudlfare I then ended up with 404 errors on a a good number of pages.

Just tried again as I was writing this post and there they were as if there wasn’t any problem to begin with. Mind you, I did clean out the caches everywhere after each instance.

Is this normal?


#2

How long were they pages returning 404? And did they return before you turned back to :orange:?


#3

Had tested it out on various browsers before panicking and setting it back to cloudflare. lol


#4

Ok, so the issue didn’t resolve until you turned Cloudflare back on. Then if you turn it off again the issue returns. Is that the case?

If so, that means that there is an issue with the origin that is preventing access to Cloudflare for those pages. This is typically an issue from the hosting provider. Have you made sure that Cloudflare IPs are whitelisted at your origin?


#5

Also could be your SSL setting. What have you been using?


#6

At Cloudflare:
Under Crypto: For SSL, using Full (strict)
Always use HTTPS: Off
Automatic HTTPS Rewrites: On

From within my wordpress setup: Really Simple SSL plugin


#8

Yeah, the folks at my server recently “installed mod_cloudflare on my server to properly give litespeed the ips visiting your site.”

Not entirely sure if that’s what you were referencing.

BTW, I do appreciate your spending the time with my question. :slight_smile: