Disabling Always use HTTPS not working

#1

we created domain alias for webhooks
added that as grey cloud on cf dns
disabled Always use HTTPS
but alias still redirects to https
how to fix?

0 Likes

#2

Can you post the URLs in question?

0 Likes

#3

no i cant
i can only give examples:
here is alias:
examplealias.oursite.com
domain:
oursite.com

webhooks doesnt work as it goes to https (somehow the payment gateway does not support cloudflare’s ssl as its another problem)

0 Likes

#4

Well, considering you already switched to :grey: Cloudflare should not be involved at all any more. Without knowing the domain it is impossible to say more.

0 Likes

#5

no it still involving as its redirecting to https

ok we’re giving it:
1)
webhook alias
you can see it goes to https
2)even when we disable "always use https " option

0 Likes

#6

Yes, that host is :grey:, so all requests go directly to your server and any settings on Cloudflare do not take effect for that host.

0 Likes

#7

i think u dont get it
it redirects to https
maybe its a cpanel autossl problem?

0 Likes

#8

Thats not a Cloudflare issue then, thats something you need to fix on your server and its configuration.

0 Likes

#9

uninstalling the lets encrypt ssl for that particular alias leads server to error

0 Likes

#10

I presume you still redirect to HTTPS. In that case it is logical that you will receive an error if you remove the certficate.

Again, this is not a Cloudflare issue and should be probably taken to a more appropriate forum.

However, what is it you are trying to achieve? Do you want that communication of HTTPS or not?

0 Likes