Disable SSL validation when using CloudFlare DNS Proxy

Disable SSL validation when using CloudFlare DNS Proxy.

Hi im new here, i cant post new toppic.
We have an online store on the integrated store platform, “VTEX”.

When I configure CloudFlare’s DNS proxy the SSL Certificate validation is no longer recognized by our platform.
This impacts the indexing of search sites.
When accessing the site, it still appears with a certificate, but it is not recognized in the index.

If you leave without a proxy, the dns is vulnerable.
What can be done in this case? I don’t have access to the certificate settings on the origin server, as it is developed by the platform’s employees.

We are suffering from DDOS attack.
I’m using CloudFlare’s dns!

That happens in certain situations, and solutions vary depending on exactly how your platform validates cert requests. Do you know if it’s using a file in .well-known, or is it using DNS?

Thanks for help.
I don’t know about that, I use those virtual store platforms. They validate the automatic certificate, and using cloudflare with dns fails to validate ssl.