Disable SSL on a specific page

Hello,

I am currently trying to disable the free SSL from Cloudflare on the main domain (example.com) but I want to be able to continue using it on the subdomains (*.example.com), I have tried to create a rule to disable the SSL but when I do it I get the error “Too many redirects”.

Greetings,

Thank you for asking.

You can disable or change the SSL option to some on a specific path or a sub-domain by using Cloudflare Page Rules.

Sounds like you’ve used or are using Flexible SSL and/or doing redirection from HTTP to HTTPS on your origin host/server? :thinking:
Otherwise, you do not have a valid SSL certificate installed at your origin host/server for your naked (root) domain?

Have you had Always Use HTTPS and/or Automatic HTTPS Rewrites options enabled too? :thinking:

Hello
Thank you for your response

I am currently using Full SSL and have disabled https->https redirection from the origin host.

Before migrating to Cloudflare the SSL was displayed correctly, so I assume it was correctly installed.

Yes, they are enabled. Should I disable them?


This is the rule configuration I’m using

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.