Disable Mirage

I enabled Mirage on my website a while back, and I’m doing some active development so I wanted to disable it temporarily. I went to the Speed tab and disabled the Mirage option. I also created custom Page Rules to “Disable Performance” (I know that sounds silly). Finally I flushed the cache. After all this I’m still seeing the mirage script injected on my page. I can’t seem to get rid of it. Any ideas?


I only have Mirage enabled from my Speed tab, so my Page Rules have no bearing on it.

So I’m seeing the mirage2 script from ajax.Cloudflare.com. Is this how you’re seeing it?

When I disable Mirage from the Speed settings tab, it no longer shows up.

Solved the problem. The underlying resource was actually being served by another Cloudflare hosted domain, so that’s where the script was being injected.

Just an FYI, Page Rules have a Mirage or a Disable Performance option (which disables Mirage and a few others), so even if you have the Speed option on, you can override it with a page rule.

This topic was automatically closed after 30 days. New replies are no longer allowed.