Disable minify in Cloudflare Pages

Hi, I’m getting errors in my nuxt.js application that appeared about a week ago whenever I deploy. For example here: 18k Recycled Gold Ring with your Secret Message in Light - FACETS Ring - THE RAYY Fine Jewelry Studio

This happens even when I use old commits that used to work fine. After a lot of looking, I tracked it down to this: Cloudflare and Vue SSR; Client Hydration Failures | End Point Dev which tells me to disable minify.

However, I can’t seem to find anyway to disable this in Cloudflare Pages. Is there any solution?

Hey, you can disable this on your custom domain here: https://dash.cloudflare.com?to=/:account/:zone/speed/optimization

We do not have minify enabled for pages.dev zones.

2 Likes

It is disabled on my custom domain and there it works fine, but if minify is not enabled on pages.dev zones, why would this error occur? It does not occur locally, on the custom domain, or on the same configuration on netlify.

Also it is a recent change as the exact same build worked March 18 but didn’t March 25.