Disable invalid certificate

cdn

#1

Hello, help please.
When HTTP Proxy (CDN) is off, the certificate(Cloudflare) is invalid. How can i disable this invalid certificate? I want to use Let’s encrypt.


#2

That would indicate you have that invalid certificate configured on your server. You will need to change the configuration and install the LE certificate you were referring to.


#3

What configuration needs to change?
only for 1 subdomain need to be real ip address and valid certificate, others subdomains and domain use http proxy and valid CloudFlare’s certificate (Comodo)


#4

Your server configuration.


#5

I have successfully install LE Certificate on my server. But when i open browser https, certificate is Cloudflare (Invalid)


#6

b24.wdex2.com


#7

What changes must i to do in Cloudflare crypto menu?


#8

You installed a Cloudflare origin certificate, which is good, however you need to proxy your traffic through Cloudflare in order for it to be accepted.

Change the DNS entry from :grey: to :orange: and make sure your SSL mode is “Full strict”.


#9

But its need REAL IP for my subdomain! + Encryption


#10

What do you mean by that? Why cant you proxy through Cloudflare?

If you cant, you cant installed an origin certificate and you will need to install any other publicly valid certificate like LetsEncrypt for example.


#11

yes, but how turn off Cloudflare certificate only for one subdomain?


#12

I am not sure what you mean. Can you proxy b24 through Cloudflare or not?


#13

In this instance the traffic is going direct to your origin. So you should remove the Cloudflare origin certificate from that server if you’re planning to use a Let’s Encrypt cert instead.


#14

Thanks


#15

So can you proxy that host or not?


#16

for my server b24.wdex2.com ip address must be 176.126.70.90
if proxy through Cloudflare ip address will change. That is not possible


#17

In that case