Disable https rewrite in specific anchor tag

ssl
autohttps

#1

Hi! I have enabled auto https rewrites inside my web page code, so far so good, but for a specific anchor tag, I need the href to be http and not https, no matter what I do, it always get rewritten to https. Is there anything I can add to an anchor tag to tell cloudflare not to change http to https for that specific tag?

Thanks!


#2

This leads to an outside url?

My point is you can use //url.com with no preceding http: or https: - not sure if this will work in your case but it’s pretty standard when you want to specify a url without or with ssl.


#3

Hi @Stuart! Sadly that doesn’t work in my case, because using //url.com causes to rewrite to https://url.com.

I need to know how can I tell CF that this tag <a href="http://url.com/" target="_blank">click here</a> don’t get rewritten to <a href="https://url.com/" target="_blank">click here</a> (note the ‘s’ in the href parameter)


#4

If it’s your site… you can disable our automatic https rewrites if your code doesn’t need it. It’s intended to help fix mixed content issues for sites with non-technical users. If you’ve already fixed your code then fighting against it in this instance isn’t providing any value.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.