Disable HTTPS redirect for CNAME

I currently have these two A records:

  1. *.domain.com
  2. *.sub.domain.com

I now want to add a cname record for sub.domain.com that points to something like xxx.nodes.xx.k8s.ovh.net. For some reason, I couldn’t access that URL via https. Therefore, when I add it to CF, I want to disable https redirects for it.

Steps I did:

  1. added the record and enabled proxy for it
  2. I created a configuration rule for (http.host eq "sub.domain.com") with these configs:
    • Automatic HTTPS Rewrites: off
    • SSL: Off

However, I get timeouts when I try to access http://sub.domain.com:32000/docs. But when I turn off the proxy, the domain works fine (chrome sometimes redirects to https but it works when I use curl)

What did I do wrong?

Aside: it would be really helpful if someone could suggest a way to allow me to easily serve https from http://sub.domain.com:[port]/docs (k8s node ports). Using flexible SSL didn’t work, and I cannot install a cert because this is a managed k8s nodes load balancer or something like that.

Thank you

The Cloudflare edge only listens on these ports (unless using Cloudflare Spectrum)…

You can use subdomain.example.com without a port and tell Cloudflare to connect to your origin on port 32000 using origin rules…

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.