Disable HTTP to HTTPS But not work

Hi ,

I was disable HTTP to HTTPS base on develop requirement. the website must be use HTTP and it’s not work, I still always redirect to HTTPS.

But the website need proxy to cloudflare for protection, now, it’s only DNS.

Please help.



You need to set SSL/TLS to OFF and disable Universal SSL. Please see this answer to a similar topic for details:

1 Like


Thanks for your answer.

Simply to say, I have a lot of subdomain and I just want 1-2 subdomain to disable SSL.

I don’t want to disable Universal SSL, because some domain also need that, the point is why I need to disable the universal SSL? I just want cloudflare not force direct to HTTPS.

There are 2 function.

  1. Disable universal SSL.
  2. Disable force HTTP to HTTPS, it’s not conflict the SSL, I can choose HTTP or HTTPS.

It’s not make sense.
No offensive.

Not possible. As explained in the post I linked to, the redirection http > https is forced by Chrome and other browsers based on a DNS record Cloudflare generates for all domains under Universal SSL. This is a zone setting, so if Universal SSL is enabled for a domain, it’s also enabled for all its subdomains.

Cloudflare offers no way to only generate the HTTPS-RR for a hostname, but not for other hostnames within the same zone, but feel free to open a topic under Feedback > Feature Request category.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.