Disable 302 https redirect especific url port 8080


For this domain the “Always Use HTTPS” is set to OFF, also “SSL/TLS encryption mode” is Flexible.

We created a dns record proxied like this: subdomain . domain . com.

We want to use http and port 8080 on the server, and do not redirect to https.

For the http port 80 it´s ok, we got HTTP/1.1 200 OK.

But, for http port 8080 it´s not ok, we got HTTP/1.1 302 Found and redirect to https.

There is a way to create for example a page rule to overwrite this redirect?


:point_up: might be the issue here.

May I ask have you had Always Use HTTPS and/or Automatic HTTPS Rewrites options enabled too? :thinking:

Try disabling both of them.

I’d suggest you to disable SSL for the particular sub-domain with Page Rules.
Therefrom, HTTP-only would work as expected with the supported port.

Maybe, there is a catch, if the SSL option executes before Page Rules.
If so, then you’d have to disable SSL completely under the SSL tab for the zone.
Afterwords, creating Page Rule(s) to enable SSL on your example.com and just in case create a 2nd one to disable SSL on subdomain.example.com.

Personally, I use HTTPS everywhere which is why I am not 100% sure and writing the above suggestion.

Hello fritex,

Unfortunately we can not change the “SSL/TLS encryption mode” to Off, there are other DNS record proxied and in production on this domain.

To clarify we tried to add a page rule, on the first position a very specific one, something like this:

subdomain.example.com:8080/* >> SSL: Off

The second rule is:

example.com/* >> Always Use HTTPS

We still got the same issue.

Also we tired for a while disable the second rule.

But in both cases we still got the same issue.

Thanks for you help!

Found the root of the issue. The customer Apache was redirecting the call.