Didn't hide my server ip?



I point the nameserver to cloudflare’s and then point back to my site server, but recently I ping my site it returned me the real server ip instead of cloudflare server’s ip, what’s wrong?
I did check and I didn’t turn on the development mode either pause cloudflare…

Any ideas ?

Thank you.


You’re either not using Cloudflare’s name servers, or your DNS entry is set to :grey:.

It also sounds like you’ve been changing name servers, which could take 48 hours for DNS to propagate.