Device Posture: Firewall on Linux and FreeBSD

Hello,
I’ve added some rules to block entire network and http/https is a firewall isn’t running on the device running warp client.

My actual test on RHEL 9 does that it’s working fine because I can’t add firewall check for Linux.

Can you add the check for firewalld service?

In CLI, I can check it using:

  • systemctl status firewalld.service
  • service firewalld status

The actual output on this laptop is:

● firewalld.service - firewalld - dynamic firewall daemon
     Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-10-20 19:14:19 -05; 2h 9min ago
       Docs: man:firewalld(1)
   Main PID: 977 (firewalld)
      Tasks: 2 (limit: 35861)
     Memory: 31.8M
        CPU: 716ms
     CGroup: /system.slice/firewalld.service
             └─977 /usr/bin/python3 -s /usr/sbin/firewalld --nofork --nopid

Oct 20 19:14:16 lab01 systemd[1]: Starting firewalld - dynamic firewall daemon...
Oct 20 19:14:19 lab01 systemd[1]: Started firewalld - dynamic firewall daemon.

It’ll be also interesting to have this option for FreeBSD with pf

Thanks