.dev domain not correctly resolving [using non-standard HTTPS port]

dash-dns
dash-crypto
#1

I registered a .dev domain through Google Domain a couple days ago, and added the domain to Cloudflare. I have 2 A records, one to point the root domain lullaby.dev to my external IP, the other to point the subdomain www to the same IP (identical to how my other domain is setup in Cloudflare). Everything looks good, but the domain doesn’t seem to resolve to my server’s IP. Currently, it resolves to 2 Cloudflare IPs. I get the same results when I’m outside of my network (I have a Pi-Hole DNS server running on the network, so I wanted to rule that out):

$ dig lullaby.dev 1.1.1.1

; <<>> DiG 9.9.5-3ubuntu0.19-Ubuntu <<>> lullaby.dev 1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60376
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1280
;; QUESTION SECTION:
;lullaby.dev. IN A

;; ANSWER SECTION:
lullaby.dev. 178 IN A 104.27.145.58
lullaby.dev. 178 IN A 104.27.144.58

;; Query time: 8 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)

Note: Router sends DNS requests to the Pi-Hole DNS server which either forwards them to 1.1.1.1 or blocks them, if they are in the blacklist.

I read some comments indicating this is normal, and is due to Cloudflare protecting your IP. The problem with that is my other domain setup in Cloudflare resolves to the correct IP. I would expect the same behavior there, as well (both free sites). It’s been over 24 hours since I added the A records. I’m by no means a pro when it comes to DNS, so I’m probably missing something here. Any suggestions?

#2

I forgot to mention that I did indeed set the custom Cloudflare nameservers at Google Domains.

#3

The behavior is correct. If your records have :orange: next to them in the DNS tab then they are proxied and protected by Cloudflare, if they have :grey: they are not and they will return your server’s IP. You can switch between the nodes by simply clicking on the cloud.

1 Like
#4

When I disable Cloudflare proxy, the domain resolves correctly and I can visit the website, but with it enabled, it just times out. That seems wrong to me. Is that the expected behavior?

#5

Well it depends on the configuration of your server. Are connecting via HTTPS? What is the SSL setting in the Cloudflare dashboard? Is your server configured to support HTTPS?

#6

Sorry, I should have provided more information. I am connecting via HTTPS. I have valid SSL certificates from letsencrypt. SSL is set to full (strict) in Cloudflare. I just confirmed that the certificate is in place, is for the correct domain, and I can view it in my browser. Full (strict) should work. Is it required to use port 443? It occurred to me that perhaps Cloudflare doesn’t like that I’m trying to access a domain via HTTPS on a non-standard port (444).

1 Like
#7

Yeah, that port is not supported. Use standard ones.

Cloudflare supports these ports.

2 Likes
#8

I was coming here to say that I found the list of supported ports, but you beat me to it! That is the solution. Thank you for your fast and helpful replies! I appreciate the help.

closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.