Despite deleting a page rule, the rule is still active

Hi, for one of my domains, I had a simple page rule redirecting this secondary domain to the main domain like this :
example.abc/ toward https://$1example.tech/$2 (permanent redirection 301)

Then, I decided to deactivate this page rule. As it seemed to still be active, I deleted the page rule, purged the cache and… I still have the redirection.

Does someone have an idea what causes this issue ?

A 301 is typically cached by your browser. Clear your browser cache.

Hi Sandro, thank you for your answer but I have of course tried with several browsers, and several devices for several days (and I have cleared the cache several times). It doesn’t seem to be the issue here.

Whats the domain?

the domain is coorpacademy.biz

It only gives me a redirect to http://www.coorpacademy.biz/en/.

$ curl -I http://coorpacademy.biz
HTTP/1.1 301 Moved Permanently
Date: Mon, 07 Oct 2019 09:56:30 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive
Vary: Accept-Encoding, Cookie
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
X-Redirect-By: Polylang
Location: http://www.coorpacademy.biz/
X-Kinsta-Cache: MISS
X-Content-Type-Options: nosniff
CF-Cache-Status: DYNAMIC
Server: cloudflare

What is that ?

It is not at all what I am getting

Whenever I use https://www.coorpacademy.biz/, it redirects me directly (and always) toward the .com

I know there is no such redirect in place as I have deleted it myself… and yet, on several different browsers on different devices, despite clearing the cache, the .biz is still redirected toward the .com.

It doesn’t come from the browser (if it was the case, it wouldn’t happen with a different browser). If it did, I wouldn’t be posting here for help…

Well, for starters, coorpacademy.biz does not “redirect” at all. It only is www.coorpacademy.biz where you experience that.

Then, it is not a redirect, but a JavaScript snippet which loads the .com page

<html><body><script>window.location='http://coorpacademy.com'</script></body></html>

So it is not page rule related but originates from your server.

Except that there is literally nothing on any server in that case : the DNS is set up toward Cloudflare and that’s it (I set it up myself). Until a few days ago, the page rule was the only thing set up for this domain. Now, it should follow the DNS settings toward the new IP address but it doesn’t.

There must be a bug somewhere on Cloudflare. I just don’t know where.

That is extremely unlikely in this context.

Do you feel comfortable sharing your IP address here?

And assuming that your IP address ends in 68, we now have the proof that it comes from your server

$ curl --resolve www.coorpacademy.biz:80:x.x.x.68 http://www.coorpacademy.biz
<html><body><script>window.location='http://coorpacademy.com'</script></body></html>

Again, that is not Cloudflare - let alone page rule - related but something thats need fixing on your server.

No, I would prefer not to

OK, but I have this problem specifically with this domain that is on Cloudflare and I don’t have it with another domain pointing toward the same IP address independently.

It doesn’t

But there is nothing set up for this domain but Cloudflare

Strangely, that IP returns the very same content that Cloudflare does. Also, why would some random server return your other URL?

Could it simply be that your DNS records point to a previous host? Check them.

If you prefer to let me know the IP address in private you could run a check against it at sitemeer.com and post back here the time when you ran it.