Desktop site ok, mobile not updating

Hi everyone,
Running into an unusual issue and tried everything(purging cache, developper mode…).
Here is the context, I have no cache system on my wordpress, I host it with infomaniak, and i use cloudfare.
Yet some pages are not updated on mobile but are on desktop. It looks like time stopped on mobile version. (those are only for paginated pages).
for instance we have this page :
https://umanz.fr/category/a-la-une/page/2
which is perfectly fine on desktop yet bring back old article on mobile,matching page 7 on desktop)
https://umanz.fr/category/a-la-une/page/7

Other example

Other element that convinced me this is a cache issue. If you crawl this URL with your mobile:
https://umanz.fr/category/a-la-une/page/2 it doesn’t work
yet if ever you add query parameters at the end of it.
https://umanz.fr/category/a-la-une/page/2?param=value (now it is working)

if i use my theme to put my website on maintenance mode, it work except for those specific pages.

Does anyone have the same issue? or can explain me what I am missing ?

Page 2 on my phone looks the same as Page 2 on my desktop.

Is your mobile on the same WiFi/Network as your desktop computer?

Also, try this link on both:
https://umanz.fr/cdn-cgi/trace
They should have pretty much the same results.

Yes same wifi network !
what is the first article on page 2 then ? as for mobile I have “et voici la climate fashion”.

regarding your link, then it displays a 404 not found

Page 2 starts with Et voici la climate fashion on my desktop and mobile.

You get 404 on Desktop and mobile?

Page 2 starts with " Dictionnary of obscure sorrows" on our desktops,which is what it is actually supposed to show on both.
Btw, I need to precise that you need actual physical device.(chrome mobile smulator doesn’t show the same bug) .

Regarding your link I have 404 on desktop, but not on mobile. shall i copy and paste the technical info ?

I’ve tried on my desktop and physical phone. Both are on my home’s network.

If you’re getting a 404 on Desktop, then it’s not going through Cloudflare. That means you have an
opposite problem. Cloudflare is not pointing to the place you’re doing your updates. And your Desktop, for whatever reason, is not using correct DNS.

You can use your browser’s Dev Tools (F12 for Chrome) and use the Network tab to check your requests and responses.

Ok then that would explain a lot of thing, except how can i clear that cache from cloudfare ? the first article of page 2 is the one that popup on my desktop " Dictionnary of obscure sorrows".

Then how come that using same rooter for wife I would have two differents DNS?
on my desktop, google developper tools indicate : 83.166.138.28:443

Is that 83.166 address what you have in Cloudflare DNS? The rest of the world is using Cloudflare DNS for your site:
https://www.whatsmydns.net/#A/umanz.fr

We are getting further from the solution, for if everybody use Cloudflare then everybody will have the problem. How can I fix it ? how can I ask Cloudflare to update its cache ? (purging didn’t solve anything) so I will have “Dictionnary of obscure sorrows”. as first article on page 2

I have no idea where can I check the Cloudflare DNS ?(I used infomaniak which automaticaly put the setting).

The IP i gave you come from google developper tools (remote IP).

Regarding your statement, then it is not entirely true. I am in south east Asia and have that issue (that dissociation between mobile/desktop) while accessing the website from the same Router. the actual webmaster is having the same issue from Paris, and some reader arround France as well.

You said you tried Development Mode at Cloudflare. That bypasses any caching. If you want to troubleshoot further, use the Overview page and click “Pause Cloudflare on Site” in the bottom right corner.

What I see is this:

  1. Your domain is using Cloudflare for DNS, as evidenced by WHOIS and the DNS lookup I posted earlier.
  2. Visitors following advertised DNS are not seeing the updates that you see when you don’t use advertised DNS.
  3. My mobile view of your site matches my desktop.

If Infomaniak is in charge of your configuration, you need to contact their Support department. It’s possible what you’re updating is not connected to their Cloudflare configuration for your website. It’s also possible that you need to flush your desktop’s DNS and/or check for a local Hosts file.

Regarding DNS :
I just flsuhed my DNS, it didn’t change anything.
But given that DNS are linked to DHCP on our local network there is no reason why one device might have a different configuration or DNs record, moreover we installed Cloudflare 9-10 month ago.

Can the issue be linked to your specific mobile architecture ?

I also disabled Cloudflare and put developer mode, but yet no change ! Except that this page https://umanz.fr/cdn-cgi/trace is no more accessible on mobile.

Mea culpaThere was a left over of a cache plugin in the .htaccess file, which was the source of my sorrows. My apologies for wasting your time on this, and my thanksfullness for trying to help me with my issues.

I will post here the increminated line in order to help a potential user having the same issue

RewriteRule ^/wp-content/hostinger-page-cache/ - [L]
RewriteCond %{REQUEST_METHOD} !POST
RewriteCond %{QUERY_STRING} !.=.
RewriteCond %{HTTP_COOKIE} !(wordpress_test_cookie|comment_author|wp-postpass|wordpress_logged_in|wptouch_switch_toggle|wp_woocommerce_session_) [NC]
RewriteCond %{DOCUMENT_ROOT}/wp-content/hostinger-page-cache/1/_index.html -f RewriteRule ^(.*) /wp-content/hostinger-page-cache/$1/_index.html [L]
Regards
M. TOULISSE Eric

2 Likes

I’m glad to hear it’s working properly now.

Solved