Deployment Failing rubygems Version

Never had an issue with Cloudflare Pages until now. No builds will complete of any Jekyll site hosted from Github. Error:

13:10:19.598|Fetching gem metadata from
13:10:19.653|Resolving dependencies...
13:10:19.690|sass-embedded-1.57.1-x86_64-linux-gnu requires rubygems version >= 3.3.22, which is incompatible with the current version, 3.1.2
13:10:19.719|Error during gem install
13:10:19.723|Failed: build command exited with code: 1
13:10:20.599|Failed: an internal error occurred

Has previously built without issue, and I’ve made no changes to anything recently other than text on templates. Not sure why this would fail, for as far as I know there is no way for users to set specific rubygems versions.

1 Like

Same here !

I resolved this by changing the Jekyll version in my Gemfile to Jekyll 3. I did 3.8.5. This should lower the plugin version and the rubygem version required.

However, this is def something that changed on Cloudflare’s end.

1 Like

Nothing has changed on Cloudflare’s end, my guess is some new version of a tool was released and broke this. I do not know enough about the Ruby eco to know what though.

Hello guys, I got the solution.

This was an issue on Jekyll side:

The solution for me was:
If your site has a Gemfile, you can lock the plugin to the older version with entry gem "jekyll-sass-converter", "~> 2.0"

But they gave other options there:

1 Like

Thanks, setting mygem file to:

# Gemfile
source ''
gem 'jekyll'
gem "jekyll-sass-converter", "~> 2.0"

Has resolved issue.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.