Deleted CNAME is still valid

Hi,

in the beginning I had a CNAME redirect from my domain “somnet.at” to my previous free domain “somnet.spdns.de”. I have deleted this record on the DNS page in cloudflare. Yet whenever I type “somnet.at” into a browser it always redirects me to “somnet.spdns.de”. (this free domain is not used anymore)

I then tried to add this record again and as I had feared clourflare told me that this record already exists and can’t be added again. So this looks to me like the old CNAME redirect is still valid somehow.

Am I missing something or do I really need support from cloudfare to resolve the issue?

BR
Markus

Hi @markus_sommer,

Your site doesn’t redirect for me, the DNS records you have setup look OK, your domain points to the 82. address that you have configured on the hostname it is CNAME’d to. I suspect the redirect or old record is cached somewhere at your end.

You can’t add that record back, because you already have a CNAME for your domain.

Hi @domjh,

thanks for the reply. It pointed me in the right direction. At the time when you tried this my server was not running. When it is running I see this redirection I mentioned. So I checked some scripts which are being run while installing this server. I found the issue. I re-ran the script with my new domain and now there is no redirection happening.

So while this was not a Cloudflare issue I’m still thankful for verifying that everythign was correct on that end.

BR
Markus

1 Like