Delete a domain (remove it)

Hi there,

I am want to delete my domain, stop paying for it, and purchase it on another site, as Cloudflare doesn’t seem to be compatible with Tumblr.

How do I do this, I have made it inactive, but it still appearing,

Which domain is it?

If it is not registered with Cloudflare, you can simply change nameservers. If it is, I’d highly discourage you to “delete” it. Someone else will register it.

Also, Cloudflare should not be “incompatible”.

But again, what’s the domain?


It’s one of mine called

I believe no one will purchase it, and ill do it on another site.

I tried to set it up with Tumblr to use as a domain, and it didn’t work at all, and seems Cloudflare doesn’t work with Tumblr anymore.

All right, that domain is registered with Cloudflare and is not yet eligible to be transferred. As mentioned, I would strongly discourage you to try and drop the registration and someone else may register it.

Why do you think Cloudflare does not work with them? You only need to configure the right DNS records on Cloudflare, that’s all.

Your naked domain seems to be properly set up, though for the www record they recommend a CNAME entry, rather than an A entry. That may be the issue, but that’s something you need to clarify with your host.

Apart from that issue, the DNS setup seems to be all right and if there are content issues, that’s outside of Cloudflare’s control I am afraid.

HI there, I see.

Yes it has actually worked, when I tried after just purchasing it I kept getting an error message. On Tumblr, but now after a week it has worked, so probably just needed a few days set up.

Thankyou for your quick responses,

Still a bit unsure as to what I did tho!

Your naked domain actually works fine →

There is an issue with “www”, because your host did not issue a certificate. Maybe mentioned CNAME will fix that, but that’s something Cloudflare can’t tell you. You need to contact your host and clarify with them as to why they did not issue a valid certificate for “www”.

Switching “www” to a CNAME entry should actually fix it.

Best is you re-visit your host’s instructions and make sure you followed all of them.

Alternatively you can also try Redirect to

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.