Degraded status on Zero Trust Tunnel connection from homelab

I’m getting the degraded status in a tunnel in the zero trust dashboard, and honestly I have no clue where to even start the troubleshooting.
The issue only happens in my local server, running Ubuntu server as a VM inside proxmox, I have also a Digital Ocean droplet setup (with another account) that connected flawlessly, it is also a Ubuntu server machine. Somehow I get the same degraded status no matter how I run the tunnel service, I’ve tried as a Docker Container, as a service running directly on the Ubuntu server with default config with webui, as well as a custom config directly with the cloudflared cli tools.
I get this warning messages in the logs of the app:

WRN The user running cloudflared process has a GID (group ID) that is not within ping_group_range. You might need to add that user to a group within that range, or instead update the range to encompass a group the user is already in by modifying /proc/sys/net/ipv4/ping_group_range. Otherwise cloudflared will not be able to ping this network error="Group ID 0 is not between ping group 1 to 0"
WRN ICMP proxy feature is disabled error="cannot create ICMPv4 proxy: Group ID 0 is not between ping group 1 to 0 nor ICMPv6 proxy: socket: permission denied"

I don’t know if it could be the origin of the issue.

i have the same problem too ,i dont why,and i do not know how to fix