Default is not going to http://

When people visit my website without the http(s) in the beginning of the link, they by default go to HTTP link instead of HTTPS, which make sure that the links of my website show up as NOT SECURE. Howcome my links are not by default routed to https://?

Can anybody help me please?

Would appreciate the help,

Filip

If your site is on Cloudflare, you can enable the ‘Always Use HTTPS’ option in the crypto tab of your dashboard to redirect all visitors to the secure version of your site.

I switched it now. It was turned to off. Do you know when the changes would be in effect and why?

Because all my links without http(s) … always go to http.

There may be some cached values on your end, however, it should start working fairly quickly now you have changed it :slightly_smiling_face:

I hope so man. If it does, you’re the hero of the day !!

Assuming your website is the top one I get in Google when I search for your username, I am already redirected to HTTPS (with the Cloudflare certificate). It may take more time for this to be reflected on your end because of cached values.

Hopefully, it works for you!

The OP’s description smells of absolute links with the protocol specified :smile:

I thought that… but having a (very) quick look at the assumed website

I can’t see any issues!

I didnt stalk - ehm, I wanted to say dig :smile: - that deep.

:crazy_face:

1 Like

Could it be something here.

all the www. links of my website … point to the https … but without the www it doesnt’.

so if you type in your browers www.habitbootcamps.com/followup it 'll take you to the https links

But if you type habitbootcamps.com/followup, it 'll take you to the http links.

Here you can see screenshot of settings.

Hello guys

when you type any link of my website (habitbootcamps.com)

when you type www.habitbootcamps.com/distractiondestroyer for instance, it will take you to https://

but when I insert the link without www.

like habitbootcamps.com/distractiondestroyer, it takes you to the http link (which is NOT secure in Google Chrome), do you know what is causing the problem here?

Here you can see the settings:

41 31

Sorry for the delay in replying. Did you definitely enable the ‘Always use HTTPS’ setting in the crypto tab of the dashboard? I would expect this to load the secure version whichever was used…

www works because you have included the https in the page rule, but it should work with that crypto setting enabled.

Yeps Crypto setting is enabled. (Changed it an hour ago).

Sorry, never seen this before, maybe someone else can notice something I am missing!

Yeps, pulling my hair out on this one and don’t understand it.

:face_with_raised_eyebrow:

There were 18 minutes inbetween your responses? Are you on Cloudflare’s payroll at this point and are your responses timed now? :smile:

1 Like

:joy:

I wish!

Just being overly polite and good to customers! The second post prompted it…

I wish paid support employees*) came with that attitude :wink:

*) Ehm, sorry, “Customer Success Agent” is the thing these days, isnt it? :smile:


@habitbootcamps, your naked domain most likely does not go through Cloudflare, respectively not through Cloudflare for your account. I would assume you set up a CNAME pointing to some other service (which also uses Cloudflare) and hence your naked domain cant be set to :orange: but is set to :grey:. This will imply none of the page rules will work in this context.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.