Default backend - 404 error

When I pause Cloudflare on site, everything is fine, the SSL license is also valid and there is no problem, but when I turn on Cloud Flair, I get this error:

“default backend - 404”

How can I fix this?

If you visit your site over HTTP with Cloudflare paused, what do you see?

What is your SSL mode? I suspect it is Flexible, but should be Full Strict, and you should enable Always Use HTTPS.

2 Likes

Hi Michael, thanks for your answer.

  • If you visit your site over HTTP with Cloudflare paused, what do you see?
  • It is automatically redirected to the HTTPS and the site loads without any problems.
  • What is your SSL mode?
  • I tested both items Full and Full (Strict) and the result is the same and it is now on Full (Strict).

Always Use HTTPS is enable.

But the error “default backend - 404” is still displayed

Please, provide the domain.

vouchermoney.com

Hi, Looking at this error:

image

I suspect that:

  1. Your web server configuration file may be misconfigured, for example something like:

image

If your web server is apache, you must go and check this file:
image

If you are using IIS, search web.config

  1. Also check that your startup file is correctly configured; that is to say; index.html or index.php; according to your source code. Since 404 means file not found, in this case, the launcher of your application.

  2. Check permissions granted to source code folders.

Using www:

image

HTTP 404 Not Found is an HTTP status code that indicates that the host has been able to communicate with the server, but the requested resource does not exist.

Thanks.

Hi, thanks for your answer.

My web server is apache,
I have deleted all the host files to make the subject clear, as you can see site loaded properly with www.

so .htaccess is configured properly.

DNS records:
A @ ServerIP Proxied
cname www @ Proxied

Unfortunately as you can see site loaded properly with www but not loaded properly without www.

I also manage 40 other sites, all of which are connected to Cloudflier and have no problems, and all have the same settings.

But this is really weird, and I believe this is a problem with Cloudflair.

Hi, your site do not load properly with www:

image

  1. Did you check folder permisions?

  2. Your DNS is working fine:

image

  1. Are you sure your .htaccess if fine?

  2. Did you check the main file of your app (index)?

Thanks

Hi, thanks for your answer.

I intentionally deleted the site files myself to make it clear that the problem is not with the files. Now I put a simple page so you can see there is no problem.

with www

without www
02

  • DNS is working fine.
  • .htaccess if fine
  • main file is fine.

*Domain connected with A record to server and the www is cname and connected to domain, so if record A has a problem, the www.domain will not work either.

*When I pause cloudflare, site load with and without www, is fine and I don’t have any problem.

.htaccess:

<IfModule mime_module>
  AddHandler application/x-httpd-ea-php74 .php .php7 .phtml
</IfModule>

I think this is because you did not configured your site with cloudflare properly due to which you are facing such kind of problems.

did you running load balancing on the server side?

Did you use NGINX Ingress Controller?

Thank you all for your answers.

Everything is fine with me, but unfortunately Cloudflare does not connect the domain to the server without www, so unfortunately I had to pause Cloudflare. You can now see that everything is loading properly.

Like I have to use another CDN.

  • did you running load balancing on the server side? No
  • Did you use NGINX Ingress Controller? No

I suggest you activate CF again (there is a lot of information exposed), I see that it redirects correctly from www to non-www; what did not happen before (it worked only with www); that’s why I think; that the error may be a routing rule in your .htaccess file or in cloudflare; if you have activated them.