Debugger is not using my timezone settings

Hey together,
for a better debugging experience the zaraz debugger should use the timezone settings from my client.
In my case it is “14:43” and not “12:43”.

Hello Complex

Zaraz Timezone settings are set on a per-browser basis through your computer’s system time & date set up. Therefore, check your machine’s system date & time settings to confirm the time zone. If the issue persists after verifying your system’s time, you might want to try clearing your browser cookies and cache as sometimes Zaraz might still reference old time zone data.


  1. Check the time zone settings on your computer. If the time zone is incorrect, please change it to the correct one.
  2. Clear your browser cache and cookies.
  3. Restart your browser and recheck the Zaraz debugger’s time.

Let me know if this helps or if you continue to experience issues.