Dead link checkers are blocked

Hi there!
We are using to validate if all pages/images/links/resources on our Zendesk support website are accessible and working fine. Starting in October we’ve started to receive 403 errors from DeadLinkChecker on the root Guide page, we’ve contacted Zendesk support and they told us that Cloudflare is blocking DeadLinkChecker IP ( and they have no control over this. Could you please check what could be wrong there and how to fix it?


Do you see the blocks in your Firewall Event Log?

I don’t see any logs there, but I think this is because blocking happens on Zendesk side.

I just ran DeadLinkChecker on a CloudFlare proxied site and it worked fine so DeadLinkChecker itself is not being blocked from accessing CF Proxied sites.
Can you share what you are seeing? (redact anything you dont want on here ofc)

We are not using cloudflare and we don’t see anything: we configured CNAME record for our Zendesk account with DNS only option and everything is happening on their side.
We tried to reach them and the answer was:

I’m a TSE here at Zendesk and I’ve been working on the 403 authentication errors. I was able to track down the error on our side and it appears that the 403 errors are due to our third party bot filter Cloudflare. Cloudflare is detecting the request as an automated action and denying access to our Help Center pages. Unfortunately, since this is expected behaviour for site crawling services and as we don’t whitelist IP addresses or have influence over Cloudflare configuration we are unable to assist further in accessing the Help Center pages.

This is an unusual message.

Even a Free Plan has basic control over various settings with the ability to whitelist (should they so choose) IP addresses and make various config changes (on paid plans, one of which they no doubt are on, there is a huge amount of configuration options).

Support here can only go so far & and as we can not alter Zendesk’s CloudFlare config, only they can, we can’t do much more.

Got it, thanks.

Will try to reach them again.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.