DDoS attack even with I'm under attack activated

Hello everyone, my server is under a DDoS attack, when you try to access my website shows Error establishing a database connection, this happens even when I have the option of I’m under attack activated, when I see my server I get the following connections :

120 87.240.129.133
100 78.46.109.245
80 13.249.198.76
67 47.245.32.56
76 202.230.136.95
7 127.0.0.1
6 184.51.48.250
6 138.229.65.59
6 13.231.224.251
5 52.69.202.199
5 47.245.55.107

Assuming that the number on the left is the number of active connections per IP address is a large number of requests so I think it is a DDoS attack.

I tried everything, blocking IPs, installing CSF, using CloudFlare, different Wordpress plugins like Protection against DDoS, I tried to get the technical support of my provider to solve the problem and they don’t fix it.

What I can do? What suggestion would you have to my problem? Thank you for advanced.

Maybe it’s your database that’s under DDoS attack. Does it ever work?

Those IP addresses are not from Cloudflare, so perhaps they are attacking your IP address directly. For better attack protection, your server firewall should block everything, but whitelist Cloudflare’s IP addresses:

Hi, try the solution of the guy above.

I have a question, do you use webhost or vps?

Another option is to opt for the service “argo cloud flare”

Someone correct me if I say something wrong.

I copy past it in all ddos posts, if you tried it all and it didnt help give us more info about the attack:
first you need to get logs, since your servers is down your will need cf to assist you with this, the easiest way is to use https://logflare.app/ or worker

after that you can use all this tools to help against layer 7 attacks:

  • rate limiting
  • I am under attack mode(not working with api routes)
  • firewall rules
  • IP Access Rules
  • User Agent Blocking
  • full html caching
  • worker
  • countries based rules
1 Like

Ok, thank you I’ll try that.

I’ts a dedicated server, so should be very fast.

Ok I will follow your comments. Thank you.