Ddclient working but not updating DNS record with IP address

Hi,

I have recently tried to update a subdomain with my IP address using ddclient (v 3.9.1) using the following configuration:

# /etc/ddclient.conf
verbose=yes

#Cloudflare config
use=web, web=whatismyip.akamai.com
ssl=yes
protocol=cloudflare
[email protected]
password=myUpdateZoneToken
zone=myzone.com
subdomain.myzone.com

Looking at the logs, ddclient seems to update the IP:

Nov  4 11:43:14 callisto ddclient[31642]: CONNECT:  whatismyip.akamai.com
Nov  4 11:43:14 callisto ddclient[31642]: CONNECTED:  using HTTP
Nov  4 11:43:14 callisto ddclient[31642]: SENDING:  GET / HTTP/1.0
Nov  4 11:43:14 callisto ddclient[31642]: SENDING:   Host: whatismyip.akamai.com
Nov  4 11:43:14 callisto ddclient[31642]: SENDING:   User-Agent: ddclient/3.9.1
Nov  4 11:43:14 callisto ddclient[31642]: SENDING:   Connection: close
Nov  4 11:43:14 callisto ddclient[31642]: SENDING:   
Nov  4 11:43:14 callisto ddclient[31642]: SENDING:   
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  HTTP/1.0 200 OK#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Content-Type: text/html#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Content-Length: 14#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Expires: Thu, 04 Nov 2021 11:43:14 GMT#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Cache-Control: max-age=0, no-cache, no-store#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Pragma: no-cache#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Date: Thu, 04 Nov 2021 11:43:14 GMT#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  Connection: close#015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  #015
Nov  4 11:43:14 callisto ddclient[31642]: RECEIVE:  93.220.126.176
Nov  4 11:43:15 callisto ddclient[31642]: SUCCESS:  subdomain.myzone.com: skipped: IP address was already set to myIpAddress.

However, I have set the DNS only record for subdomain to a certain value to begin with (1.2.3.4). And this is not being changed as a simple ping to subdomain.myzone.com only shows the destination which I have set manually, but does not use the ddclient determined IP address:

Request timeout for icmp_seq 81
36 bytes from quark.dip0.t-ipconnect.de (ip): Destination Net Unreachable
Vr HL TOS  Len   ID Flg  off TTL Pro  cks      Src      Dst
 4  5  00 5400 c9b6   0 0000  3f  01 eacc 192.168.2.120  1.2.3.4 

Am I doing something wrong? Any ideas are highly appreciated. Thanks.

A post was merged into an existing topic: DDClient working but not updating DNS with IP address