Custom Purge still not Working

The system says that it should take 30 seconds. But no matter what I do, the cache does not seem to get purged. Anyone got some ideas of what to check?

If you’re doing a Purge by URL, you might not be entering the specific URL perfectly.

It’ll act like it’s purging, but the URL isn’t perfect, then it won’t get purged.

Does a Purge Everything work?

1 Like

The URL was correct. I cannot purge the entire site. It eventually did get purged - but it took many hours. Anyone else have any ideas? (it was not the browser. It seems to be connect to the TTL - but not sure.)

Tips to check:

  1. Try a test URL which is not used for another purpose
  2. Copy the address straight from your browser address bar and paste into the Cloudflare user interface (i.e., don’t use the API to test)
  3. Make sure you are in the Settings for the correct domain
  4. Open up Developer Tools in your browser and select Disable cache or similar (or otherwise clear your browser cache before re-navigating to the URL)
  5. Keep an eye on the age and cf-cache-status headers – both should reset when you do the purge
  6. The purge should happen within 45 seconds or so
  7. If you’re using HTTP instead of HTTPS, it’s possible an intermediate cache has cached the page (but in that case the age header should still remain the same I think) so try the request from a different network and/or geographic location (Edit: Looks like age may update if an intermediate cache is responding, so with HTTP you’ll need to try the request from elsewhere(s))

If the above works, retry the URL you’re actually having trouble with.

2 Likes

Yep - did all of that.

Your test URL did not work?

The only thing I did NOT do was use a test URL which is not used for another purpose. I will need to create such a URL and rerun the test. I will update you soon.

Are you using APO ?

Since Oct 19, custom purge (purge by url) is not working on mobile devices for me.

Purge everything does not help.

2 Likes

It still doesn’t work. Anyone from the {incorrect guess at an at mention redacted} Team looking into it?

May I ask have you tried clearing your Web browser cache or by using different Web browser, just in case if the Web browser loads a cached version, rather than the new one?

It’s not a matter of browser cache because I tried both:

  • doing a hard refresh
    and
  • observing the response in the Inspector with browser cache disabled
    The edge cache age suggests that it wasn’t purged.
    Funny enough: the purge by URL works if you trigger it from the Cloudflare Dashboard but not from the API.

Hello, we are again having issues with single file purge via API as the cache is not actually purged unless we purge it via the dashboard. This is an issue that persists every few weeks/months and is causing lots of trouble for us. There’s also no way to report it unless via the forum cause the free tier’s support requests are hard to bring to an answer quickly.

Maybe there should be a mechanism to report this so it’s easier for Cloudflare to track these kind of issues?

Thank you.

Try to create a support request and post the ticket number here. We will help escalate your request to the support team.

Apparently, I cannot submit a request too, as I cannot press Next and neither uncheck the checkbox to type the domain names :smiley:

Yes, I was seeing this too… not had a reply on my notification though :weary:

Thanks a lot. I have created a request via email. The ID is [2286978].

I see that Eric has escalated this, so you should hear back today.

3 Likes

Apparently, after the 20th of October’s troubles with cache - “Oct 20, 2021 - Cache Purging Delays” our cache invalidate service has had a few stall requests which were blocking the whole execution stack. It seems to all be well now. Sorry for the trouble.

2 Likes

This is still an issue, but I cannot see any official incident.
Is anyone from the {incorrect guess at whom to mention redacted} Team working on it?

This still not working?
I wonder how my WordPress plugin using API works for Purging the cache at the Cloudflare Edge, if so :thinking:

Or I could be wrong about it.