Custom Error page code 1203

I’m trying to setup both a custom 429 and 500s error page on my cloudflare domains. I have both pages available, and I can access both pages externally.

The 500s page has the magic string in it.

The pages are more than 100 characters long for sure. They are less than the 700kb each in total (including some css and images, not sure if those are actually counted).

When I add a page to my site, I get a “Your custom page must be larger than 100 characters (Code: 1203)”

I have both Pro and regular domains, all getting the same errors. I tried different endpoints as well for my stored pages, to no avail. I also tried it on both the account level and the individual domain levels, same issues.

All sites are -not- in “Under attack mode”, I even tried setting that, and changing it back to “normal”, because maybe something was stuck? Nope.

When I click on the “Preview” button, it will show me the cloudflarepreview.com domain, and an error 500: “Status code 500 received while fetching template”, so my hunch is that something is up on the cloudflare side, but I have no way to confirm that.

Not sure how to proceed right now.

Ok, for whoever finds this at some point, I fixed it.

The 1203 is just a general error “this didn’t work, please fix it” and gives you no feedback at all. It can be several things:

  • Be sure to check your html in the w3c validator The cloudflare checker is very strict, even warnings seem to be following into an error.
  • Run and install the minifier that they use internally: https://github.com/cloudflare/collapsify They basically download your whole html, and all external resources, and that combined cannot be greater than 1.43MB (so it can fit on a floppy disk I guess?).

I included an external GA file which resulted in a waaaaaay to big file. I found a smaller version of the same script and used that.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.