Custom domains shows "Inactive (Error)" in Cloudflare Pages

I use CloudFlare Pages build my blog, but my custom domain can not be binded to it. It shows “Inactive (Error)”.

Have you tried to access the domain despite it saying that? Usually it works regardless

I used to bind my domain to Baidu Cloud (su.baidu.com)

yeah, I tried it.

Could you please provide the domain you’re trying to connect?

Also, is this domain on Cloudflare?

The Custom domain is blog.ascn.site
The Pages domain is leao9203.pages.dev

I have add this domain to Cloudflare.

Looks like your domain is not on Cloudflare and you currently have an A record for blog.ascn.site pointing to 1.0.0.0 with no CNAME

You should either add to Cloudflare or remove that A record and add the CNAME which Pages provided.

1 Like

Okay, I have done this.
I have remove the A record and add the CNAME record.

Looks like your site is working now :slight_smile:

yeah, thank you

Looks like it not work…It is cache just now…
I use Workers to make it work…But it works not well than Pages.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.