Custom domain with Blogger not working


#21

Thanks @andy and @dadepo for continuing the conversation and solving the problem!

Indeed, turning off CDN solves the problem.

To clarify for anyone looking at this thread, I am trying to use a custom domain for blogger that is NOT www. Specifically I am redirecting “blog.hanxue.co” to “hanxue.blogspot.com”, but “www” still points to my own server.

Blogger custom domain


#22

Hi !
I am unable to scanning my website. Can anyone help me ?


#23

It does not seem like the above solution is still working. The websites above no longer redirect. My website is having the same issue: i can’t redirect the .blogspot.com to https://www.electronicsdiary.com
Is there a way out o this?


#24

Thank you, you really saved me from missing with other options.


#25

Thank for those information now my site fully working with cloudflare but site loading slowly tell me any solution what the problem why site too slow after add cloudflare on blogger. Help me .Egovtjob


#26

Hi Guys,

So did you finally make it work?
I have similar/same challenge:

I have my blog on google - https://blackcatwheels.blogspot.ch
I bought domain blackcatwheels.ch
I wanted to use cloudflare to redirect google blogger to the new domain and keep using https / ssl which is crucial for me.

I did the whole setup two days ago and cloudflare still didn’t authenticate my entry…
I would be grateful for any advice

Thanks
Tomasz


#27

ok so finally my dns were validated.
The redirection from blogger to my new domain works including https :slight_smile:

Last thing which I can’t sort out is the blogger warning redirection page
I checked above posts but I don’t see the solution for this.
Anyone solved the case where user enters old blogger address (ex. blackcatwheels.blogspot.ch) and redirection works without any warning?

My DNS setup:


#29

Same problem.

I may have read this thread about 10 times to get a hang of the solution. I have a blog with custom domain - www.myyatradiary.com but when I open my old blog URL - www.myyatradiary.blogspot.com I get a redirect message. I am personally not fond of this message as it has a strong potential to turn readers away. I myself would prefer doing that, as a reader!

Anyone figured out a workaround to this problem, anyone or is it not possible? I am also curious about the current status of the redirection messages for the users above?

@dadepo @andy


#30

Blogger controls the blogspot domain, and all subdomains under it. Only they control how redirects on their domain are handled. I suggest you start bugging them to make it look better.


#31

3 posts were merged into an existing topic: Immediate Support for Compromised Account


#34

@tomasz.gomolka and @22arti,

Thanks for bumping this topic. It appears my initial findings from July 2017 are no longer accurate.

I will update my posts here to redact any misinformation that may lead folks astray.

Unfortunately this does not seem possible anymore / at this time :frowning:


#35

A post was merged into an existing topic: Immediate Support for Compromised Account


#36

I just tried this on my blog also hosted Blogger.com/ Blogspot.

I did a few things here.

  1. Set IP addresses to the same per Google’s support article
  2. Set my www as CNAME to vulongtran.com
  3. Set SSL to Full mode (use the Flexible mode if it is breaking, as origin SSL we cannot upload an origin SSL for
  4. Set a Page Rule to redirect.

#37

Google’s support article https://support.google.com/blogger/answer/1233387?visit_id=1-636598332828811106-3671295106&p=customdomain&hl=en&rd=2

Set a Page Rule to redirect.
vulongtran.com/*
Forwarding URL: 301 Permanent Redirect
https://www.vulongtran.com/$1


#39

a few same error:

  1. when I use custom domain www.cafe3f.com for my blogger 3fcafe.blogspot.com. But I click 3fcafe.blogspot.com don’t auto redirect to www.cafe3f.com (show page: You’re about to be redirected, and must click “yes”)
  2. other my blog: goigas.svtre.com when Turn on “HTTPS redirect” so don’t access (error too many redirects so Turn off “HTTPS redirect”)

All my domain use cloudflare DNS (turn on orange)
Pls help me, thanks very much


#40

#1 isn’t a Cloudflare issue. That’s completely the blogspot site that’s not automatically redirecting.

#2 is something on your server improperly redirecting HTTP to HTTPS (or the other way around). What’s your Cloudflare SSL option set to (flexible or full)?


#41

Thank you so much.
I changed from flexible to full and success for all my blog (include www.dogodongky.net and www.caytet.com)
hihi thanks for help <3


#42

Agree #1 is a a Blogspot setting. Anytime the 3fcafe.blogspot.com is accessed, with or without Cloudflare in front of it, it will show that warning message. This is to warn users who are on your custom domain www.cafe3f.com and is something that Google BlogSpot team has set the system to highlight so users know they are being redirected to another website.

I also cannot remove the warning on dejavuguides.blogspot.com or vulongtran.blogspot.com