Custom domain with Blogger not working


#1

I have set up Cloudflare to redirect www.hanxue.co and the naked domain hanxue.co to my blog http://hanxue.blogspot.com - works without any problem.

When I change the subdomain to blog.hanxue.co, the redirect does not work. Here is my Cloudflare DNS settings:

[Redacted by Cloudflare]

This is the error I got when I visit the domain:

Note that changing the CNAME entry of blog to www and updating DNS settings at Blogger to www, works perfectly fine.


Blogger Redirect with Cloudflare not Working
#2

Hi @hanxue,

I’ve redacted the DNS records screenshot you pasted in here as it contained your origin IP address which you might consider private or sensitive information.

If you have configured blogspot to serve your blog on the www.hanxue.co subdomain, then your page rule for blog.hanxue.co needs to redirect to www.hanxue.co - not to hanxue.blogspot.com. Then everything should work for you.


#3

I am replying to this because there seems to be no way for me to create a new thread (maybe this is something the moderators should look into?)

But anyways, I have similar problem. I have a blog at geekabyte.blogspot.com which I want to use the custom domain geekabyte.io for.

  • I got the custom domain via namecheap
  • I configured namecheap to use name servers from cloudfare
  • I configures my DNS settings as described in bloggers instructions on how to use custom domain

When I now go to geekabyte.io, everything is fine…

But when I go to the old domain: geekabyte.blogspot.com, I get the same redirect page:

Any ideas on how to fix this? Thanks.


#4

@dadepo you can’t create new topics immediately until you have read the forum for a while - for a bit more detail on this take a look at Trust Levels and Permissions

That said, I think you were right to respond to the same topic since this is a very similar issue so I’ll reply below.

This looks to be how blogspot behaves when you configure a custom domain. If you click “Yes” to follow the redirect you are then taken to https://www.geekabyte.io/ and everything is loading just fine via Cloudflare.


#5

You can’t create new topics immediately until you have read the forum for a while - for a bit more detail on this take a look at Trust Levels and Permissions

hmmm…maybe this should be included in the discobot welcome message? or perhaps somehow on the front-page? Not being able to ask a question and not knowing why, was a little bit of an annoyance :frowning: maybe putting this information where new sign-ups will see it might help?

This looks to be how blogspot behaves when you configure a custom domain. If you click “Yes” to follow the redirect you are then taken to https://www.geekabyte.io/ and everything is loading just fine via Cloudflare.

I do not think so. I paused the domain on cloudfare and switch to the nameservers provided by my domain register and this issue is gone. So for example, if you now go to the old domain (geekabyte.blogspot.com) you will automatically redirect to the new domain (www.geekabyte.io) without seeing the redirect page/message.

Having the redirect page is really not the best, as it will scare people off and also it will have an adverse effect on the indexing of the site by google…

Do you by chance have any idea of how to configure the DNS via cloudfare to prevent this from happening? Then I can move my domain back.

Thanks!


#6

I’m going to do another audit of the permissions and default trust levels. Hopefully we can reduce the confusion and frustration.


#7

@simon (or anyone who can help)…thoughts on this?


#8

@dadepo I was able to get this working just now using a test blog and the following steps:

  1. Log on to Blogger/Blogspot > Select your blog > Settings > Basic
  2. In the publishing section click the link + Setup a 3rd party URL for your blog
  3. Enter your 3rd party domain. It can’t be naked so it must be www.example.com or blog.example.com or something
  4. Blogger will bark at you “We have not been able to verify your authority to this domain. Error 32.” so log in to the Cloudflare dashboard in another tab and edit/add DNS settings as instructed (they want you to have 2 specific CNAME records)
  5. Go back to the Blogger Settings page you have open and click ‘Save’ in the 3rd party domain settings. Now that you have added those CNAME records to Cloudflare DNS, Blogger will save the settings and the redirect should be in place!

#9

@andy Can I ask something? When you type the old blogger URL does it seamlessly re-direct to the custom domain without a message page warning about the redirect?

This was the problem in my case.

Everything works fine if I type in the custom domain, it automatically loads the content from the old blogger URL
But if I type in the old blogger URL, it is expected to just redirect to the new domain without showing a warning page.


#10

Yes, it does - no redirect message. My test setup is live if you want to see: blogger site (404ndy.blogspot.com) redirecting to my custom domain (blogger.404ndy.com). You can test the blogger URL to see that the redirect is seamless to the user.


#11

Yes indeed! It redirects properly!
Can you maybe share the screenshot of your cloudfare DNS entries? So I can compare with what I have? Hopefully I will be able to spot what I am configuring wrong.

Danke je wel!


#12

So, a piece of critical information that I didn’t realize initially may be the culprit here: my DNS records for this are grey-clouded. After a little more testing it appears that when you orange-cloud these entries Blogger pops up the redirect message. I can’t explain this, but it may be the discrepancy between our configurations.

[screenshot redacted]


#13

Thanks for this! It will be interesting if this is indeed the case…

I had to switch my Nameserver back to my domain provider…I will now switch back to cloudfare and confirm if what you mentioned about “grey-clouding” the DNS records is the culprit here…


#14

@andy so the issue was indeed the DNS records that were grey-clouded. My domain is back on Cloudfare and now it seamlessly redirects with the message page from blogger…

Hovering on the clouds icon I see they are used to turn on (or off) HTTP proxy (CDN). It been turned on when the cloud is orange.

I am guessing introducing this proxy, this man in the middle, is what triggers blogger to scream with that message on redirect (Would appreciate if someone more knowledgeable than me will confirm/refute this).

So, I have now turned off the proxy and my redirects works seamlessly. But I think the repercussion of this, is that “https” no longer works :frowning: which kinda defeats the purpose of why I wanted to host the domain on Cloudfare :frowning:

Now I am not sure if this is a definitive situation: but it seems that I cannot have HTTPS for custom domain on blogger via Cloudfare (well unless I want to leave with the scary, annoying redirect message that blogger screams at visitors)


#15

I agree with both points based on my tests, and this HTTPS restriction appears to be imposed by Blogger as you can see on the settings page. Unless anyone else can confirm, I think - regrettably - that you may have to choose between HTTPS and bypassing the Blogger redirect page. I.e. which is more important to you: SSL for your blog (always nice to have but possibly not needed?) or the seamless transition from your old URL to your new one?


#16

Unfortunately so…

I will be going with the lesser evil of not having HTTPS…although recent push from browsers/search engines seems to indicate that this might come with some penalty, but I take that over that annoying, scary redirect page :smiley:

Thanks for noticing the effect of the orange/grey cloud icon :slight_smile: without that, would probably still be pulling at my hair!


#17

Some #Blogger blog owners want to provide blogs published to custom domains - and offer HTTPS connectivity. Since Blogger cannot provide custom domains with HTTPS right now, the blog owners are using CloudFlare, which provides an HTTPS proxy.

Unfortunately, a CloudFlare proxy looks like malicious redirection - and blogs using CloudFlare are being labeled as “Deceptive” sites.


#18

Late back to this topic but @andy your screenshot shows you grey-clouded both the verification record and the blogger record. Out of interest if you orange-cloud just the blogger record but leave the verify record grey-clouded, does this work?


#19

I did some testing and the :grey: don’t seem to matter any longer. I :orange: the blogger subdomain and have HTTPS without a redirect page.


above no longer accurate as of March 2018.


#20

So I suspect that’s because the verification record I mentioned needs to be checked once (or perhaps once every so often) by blogger. If anyone else is still having this issue try setting the cloud to :grey: next to the verification record only and leave the actual cname to ghs.google.com :orange: . I think that way the verification should always complete and you’ll still be powering your blog itself through Cloudflare.