Custom domain TLS with GH-Pages


#1

Hello and thank you all in advance! Very newbie SSL question I’m sure but … here goes

  1. I’ve had a custom domain for a few years now and hosted that site on GH-Pages without any issue
  2. That gh-pages site is hosted on the master branch using a docs/ directory
  3. I added a flexible SSL configuration for that website w/ cloudflare yesterday
  4. I updated my name servers to point at cloudflare yesterday
  5. This morning I did see cloudflare looked “complete” and working but I noticed a few things

a) on cloudflare under Crypto I see my custom domain listed as the “hosts” for the shared certificate type

ember-redux.com, *.ember-redux.com (2 hosts)

b) when I try to view the domain over https I see this information

ember-redux.com uses an invalid security certificate. The certificate is only valid for the following names: *.github.com, github.com, *.github.io, github.io

…which makes me believe I’ve not yet completed the A name record setup/or I’ve done something wrong with cloudflare. Any help would be much appreciated


#2

Hey @toranb this is for the root zone or another subdomain? The site is rendering correctly for me. You might try flushing your DNS cache and making sure you don’t have a host file entry for the zone.


#3

@cscharff this should be for the root domain of ember-redux.com (no sub domains)

I did try to flush locally w/ this command on macOS sudo dscacheutil -flushcache but same issue so I’m curious if my ISP has this cached up a level. I did jump off my local wifi w/ my iPhone and it does appear to work as you mentioned. Just one last question here - is strict or flexible better for sub domain SSL like this w/ cloudflare?

Thanks for the quick reply btw!


#4

If this is hosted at github I don’t think Full (Strict) is an option, but I believe Full will work. Could very well be cached by your ISP. Have you seen our awesome new https://1.1.1.1 ? Just kidding. :wink:

Here’s what your host resolves to for me:

dig ember-redux.com +short
104.31.83.192
104.31.82.192


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.