Custom domain starting with www

Answer these questions to help the Community help you get started.

What is the domain name?
cryptoelection xyz

Have you searched for an answer?
yes

Please share your search results url:

When you tested your domain using the [Cloudflare Diagnostic Center], what were the results?
Say it’s active

Describe the issue you are having:
I managed to configure my custom domain without www.
Now I want to configure with both options.
The cryptoelection xyz is working
So I need www cryptoelection xyz (with www is not working)

What error message or number are you receiving?
It’s opening the xyz register site saying that is underconstruction

What steps have you taken to resolve the issue?
Trying to solve yet
1.
2.
3.

Was the site working with SSL prior to adding it to Cloudflare?
cryptoelection xyz

What are the steps to reproduce the error:

  1. www cryptoelection xyz

Have you tried from another browser and/or incognito mode?
Yes

Welcome to the community!

Could you replace the A and/or AAAA records of the www subdomain with a proxied (:orange:) CNAME record pointing to the root domain?

Hope it helps!

I have an A record with www pointing to an IP address.
But that’s not working

Ok. Could you please replace that A record of the www subdomain with a proxied (:orange:) CNAME record pointing to the root domain?

Is not possible, it’s showing this error Valid IPv4 address is required

Please check that you are creating a CNAME record instead of an A record.

ahh ok.
So I need to create a CNAME with what?
www.domain?

Trying to create a CNAME www
getting this error:
An A, AAAA, or CNAME record with that host already exists. (Code: 81053)

Please ensure that you have deleted all A and AAAA records for the www subdomain. Then, verify that the created record looks like this:

image

This post may also help you:

Hope it does!

Ok, I deleted the others A and AAAA and added the CNAME as you show
Almost worked and now it getting this:
Screen Shot 2022-09-06 at 19.43.26|690x361

above

Now you need to wait and then see if it worked…

The origin site needs to be configured to serve content when it it receives requests with www.cryptoelection.xyz in the hostname header.

One way to skip setting that up at the origin is to use a Bulk Redirect to reroute all requests for the www host to the apex name, cryptoelection.xyz.

1 Like

A page rule may also be fine and easier to setup if you don’t use them (you can only use 3 in the free plan).

How long I need to wait?
It’s not working yet

I forgot the step about page rules (my bad) :frowning:.

You need to go here, and then create a page rule with the following config:

Now it should work.

2 Likes

Cool!! Now it worked!
Thank you a lot!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.