Custom domain and sub-domains stuck at verifying an initializing

I’m aware that cf facing dowtime but dns seems to be recovered and I’m facing this issue since last 2-3 hours.

Not sure whether it is completed related or what but this happened to me for the first time, otherwise adding a custom domain to a worker or pages is super quick.

My apex/root domain is stuck at initializing and CNAMEs are stuck at Verifying.

Any help and insights are appreciated.

1 Like


There was some delay in ssl provisioning last night due to:

Have these all provisioned now? If not, could you let me know the domains?


Sure, here are the domains:

FYR, I tried adding these again and now both are stuck in “initializing” and removed the 3rd one.


Thanks. It looks like there is still some lag at the minute. Note that re-adding will put them to the back of the queue so it’s best to keep them initializing/pending for now

Hopefully these should fully provision in around an hour (hopefully less).

@Walshy Ok great, thanks for the response. I’ll wait then.

@Walshy Also, is the impact for *.dev domains fixed?

Because the .dev was working fine yesterday but not anymore.


The cert is now deployed. It was caught in the same ssl provisioning delays

1 Like

@Walshy Yup, thanks, I am waiting on the www and root domain now.

Yeah I’m monitoring those, this is going way slower than I would have hoped :frowning:


@Walshy Just an update here, my domain is up and running but the dashboard still shows Initializing.

Yeah I see the hostname active but cert init here too, we may need to kick it on our side for it to go active properly but it should be good.

1 Like


l added a test cname for my pages site and it went to verifying and then active, within a minute.

Considering this, I removed the root custom domain which was stuck for Initializing and added it again but this still goes to Initializing

@Walshy Just an update, now both are stuck at Verifying

Is it possible that it is stuck for 3 days?

For about one month, we use that is a CNAME to (it was configured automatically by Cloudflare when we added the subdomain to the page) and it worked perfectly.

Last Friday we tried to add another page, then use as an alias for but it doesn’t work. works but returns “Connection timed out Error code 522”. In the CF dashboard, the custom domains tab always show the “Verifying” status.

I’d recommend removing and re-adding now domains are in a more stable place. If it is still verifying after a few mins please check the debug guide: Debugging Pages · Cloudflare Pages docs

Thanks for your answer and the link. We have a complex setup with a partial zone so it may be our issue, we’ll try to add the CNAME record to our primary DNS provider and try to add the custom domain again.

Adding the CNAME record to our primary DNS provider fixed the “Verifying” issue. :white_check_mark:

1 Like

@Walshy So when I checked today, it was in active state but to make some changes, I had to remove both the domains and as a result, I added these back and it went to Initializing again.

Let’s Encrypt is rate limiting due to being added and removed too many times. I have moved you over to GTS instead.

Can you please once again remove and re-add your domain, it should hopefully go into Active state pretty quick.

@Walshy I did that and it went to Active very quickly but now I’m waiting for the DNS propagation for a few mins.