Custom Cache via Cloudflare

Hi! I wish someone could help me out…

So I am using LiteSpeed Plugin (only To generate Critical CSS & for Page Optimization), and Swift Cache Plugin (For serving Cache, and warming up my page caches at regular intervals). Swift Plugin stores all the cache pages in a specific directory in wp/content/

Is there a way I can instruct Cloudflare to serve every page that is already cached by Swift, on every first visit?

I am trying to achieve so because there is a huge page speed score when I compare normal pages vs cached pages in PageSpeed Insights. Also, LiteSpeed Crwaler is not available for shared hosting, so I am bound to use this method to warm up my cached pages.

Kind Regards

please any help @yevgen

→ Please do not randomly tag people on the boards like that.

People will eventually come by your post after a little while, waiting ~ 90 minutes on a community board is nothing.

This kind of “warming up the cache”, is also known as prefetching in the CDN world.

Prefetch URLs is an option for Enterprise plans, assuming that the resource is already a part of what Cloudflare normally caches by default.

1 Like

Sorry! I am new to the Cloudflare community or in fact to any community discussions! I’ll take care of it!

Prefetching makes sense. Thank you!

@DarkDeviL - what if I already do “Prefetch” the URLs on my server, at regular intervals… I am only looking for a way to instruct Cloudflare to serve those files…

All the prefetched URLs end with where “?force-cached=1” is common in the end.

I did try to make a URL rewrite for that but that messed up my admin dashboard. Can I make a proper URL rewrite or something like that? and will it work?

I suggest looking at Transform Rules, the only caveat that regex support is only available for Biz and Pro plans: Transform Rules · Cloudflare Rules docs
Some examples for Basic URL transforms:
Serve images from custom paths · Cloudflare Image Optimization docs
URL rewrite examples · Cloudflare Rules docs

1 Like

Thank you for getting back.

I did go through that and it seems to be a good solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.