cURL error 7: Failed to connect to localhost port 443: Connection refused

OS version: Ubuntu 20.04 x86_64
Plesk version: Plesk Obsidian 18.0.47.5

Hi,

I am running XenForo Forum on my Plesk which running behind Cloudflare.
I get following erro log, which is showing me that the curl connection to localhost on port 443 is refused.

All curl’s to localhost, 127.0.0.1 and 0.0.0.0 are refused:

[email protected]:~# curl -vv localhost:443
*   Trying ::1:443...
* TCP_NODELAY set
* connect to ::1 port 443 failed: Connection refused
*   Trying 127.0.0.1:443...
* TCP_NODELAY set
* connect to 127.0.0.1 port 443 failed: Connection refused
* Failed to connect to localhost port 443: Connection refused
* Closing connection 0
curl: (7) Failed to connect to localhost port 443: Connection refused
[email protected]:~# curl -vv 127.0.0.1:443
*   Trying 127.0.0.1:443...
* TCP_NODELAY set
* connect to 127.0.0.1 port 443 failed: Connection refused
* Failed to connect to 127.0.0.1 port 443: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 127.0.0.1 port 443: Connection refused
[email protected]:~# curl -vv 0.0.0.0:443
*   Trying 0.0.0.0:443...
* TCP_NODELAY set
* connect to 0.0.0.0 port 443 failed: Connection refused
* Failed to connect to 0.0.0.0 port 443: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 0.0.0.0 port 443: Connection refused

UFW Firewall is disabled:

[email protected]:~# sudo ufw status
Status: inactive

netstat show me that port 443 is active and listen
image

To be sure I also have turn OFF the “Security Level” on CF Firewall.

No matter what I’ve tried, so far unfortunately without success.

I would therefore be very grateful for any tip or solution to solve this issue.

Regards.

This isn’t a Cloudflare issue because your site is not accessible locally. You would have better luck posting on server overflow.