cURL error 7: Failed connect to domain.com:443

Seems to be an issue with SSL or DNS, need some help

Without knowing what the domain in question is @angry.school.boy, it is impossible to provide any assistance.

luxroll.by

If I disable the CDN and the plugin in wordpress (Super Page Cache for Cloudflare), then everything works fine
I contacted my hosting support and got the following message:

I did an analysis, most likely from the site luxroll.by there is an attempt to access itself.
I see that Cloudflare is blocking requests on port 443 for HTTP connections, which is probably the cause of the errors.
For additional verification, I recommend contacting the site developer, temporarily disabling the use of Cloudflare and checking the operation of the admin panel.

From our server side, port 443 is available for HTTPS.

Let me know if you have any additional questions.

I doubt Cloudflare would block HTTPS/port 443—if anything they would encourage it.

I am assuming you have disabled Cloudflare as when I tried to access the site, I had no issue, and cURL requests showed an nginx server not Cloudflare.

When I do curl -I https://luxroll.by I see

cache-provider: CLOUDWAYS-CACHE-DE

If there is already a cache running on the service, perhaps having Cloudflare cache also running is causing issues.

Did you enable bot fight mode? That may be the culprit.

If there is already a cache running on the service, perhaps having Cloudflare cache also running is causing issues.

I disabled cashing on hosting server, same problem:
cURL error 7: Failed connect to luxroll.by:443; Operation now in progress

I turned on Cloudflare on my website for you to test

Enabling bot fight mode also does not help.

Try a traceroute:

traceroute luxroll.by

Trace route to luxroll.by  [172.67.214.32]

  1     *        *        *      Query timed out.
  2    65 ms    63 ms    61 ms  149.34.244.188
  3    62 ms    63 ms    61 ms  vl201.ams-dc1-core-1.cdn77.com [138.199.0.108]
  4    72 ms    71 ms    68 ms  vl1102.lon-tel-core-1.cdn77.com [185.229.188.194]
  5    69 ms    70 ms    72 ms  vl211.lon-tel-edge-1.cdn77.com [138.199.0.55]
  6    73 ms    72 ms   103 ms  cloudflare-lon.cdn77.com [45.134.215.11]
  7    71 ms    94 ms    75 ms  172.71.176.4
  8    73 ms    68 ms    70 ms  172.67.214.32

The trace is complete.

Win 10

Trace route to luxroll.by [172.67.214.32]
with a maximum number of jumps 30:

  1     *        *        *     Query timed out.
  2    65 ms    63 ms    61 ms  149.34.244.188
  3    62 ms    63 ms    61 ms  vl201.ams-dc1-core-1.cdn77.com [138.199.0.108]
  4    72 ms    71 ms    68 ms  vl1102.lon-tel-core-1.cdn77.com [185.229.188.194]
  5    69 ms    70 ms    72 ms  vl211.lon-tel-edge-1.cdn77.com [138.199.0.55]
  6    73 ms    72 ms   103 ms  cloudflare-lon.cdn77.com [45.134.215.11]
  7    71 ms    94 ms    75 ms  172.71.176.4
  8    73 ms    68 ms    70 ms  172.67.214.32

tracert (win) words fine
On some point I get request timed out, but it’s probably fine, because I get next message

The trace is complete.

I enable some http logging plugin, I get this error for next request:
https://luxroll.by/wp-json/wp/v2/types/post?context=edit

Request:

{
  "method": "GET",
  "timeout": 10,
  "redirection": 5,
  "httpversion": "1.0",
  "user-agent": "WordPress/6.0.2; https://luxroll.by",
  "reject_unsafe_urls": false,
  "blocking": true,
  "headers": {
    "Cache-Control": "no-cache",
    "X-WP-Nonce": "8a900bc443"
  },
  "cookies": {
    "wordpress_sec_bba707be1742ee003edb4071dbcfba37": "admin|1665863039|a56oT9xKjNVSCYNCYT4E5JUWUj7jG1tChpqd4OScWpQ|bd378c5baa28e88a131d67d4b44c1c98f8c258aa3bcf310d9f395e015cf301a7",
    "_gcl_au": "1.1.1675950034.1664638890",
    "_ga_89QBFZP7SH": "GS1.1.1664653414.3.1.1664655295.60.0.0",
    "_ga": "GA1.1.1160066422.1664638890",
    "_ym_uid": "1664638893957497818",
    "_ym_d": "1664638893",
    "_ym_isad": "1",
    "wordpress_test_cookie": "WP Cookie check",
    "PHPSESSID": "40d7db010e4560cb86f5482dd8b4c7ba",
    "breeze_folder_name": "48fc4ab0d398ad29e9285baee7d20eb2d23690bf",
    "wordpress_logged_in_bba707be1742ee003edb4071dbcfba37": "admin|1665863039|a56oT9xKjNVSCYNCYT4E5JUWUj7jG1tChpqd4OScWpQ|557dcc61c86d9915b6ce2c6d05e0266f70cd0e0d85d82661b13829213ad08b2c",
    "wp-settings-1": "libraryContent=browse&editor=tinymce",
    "wp-settings-time-1": "1664653447"
  },
  "body": null,
  "compress": false,
  "decompress": true,
  "sslverify": false,
  "sslcertificates": "/var/www/user2129144/data/www/luxroll.by/wp-includes/certificates/ca-bundle.crt",
  "stream": false,
  "filename": null,
  "limit_response_size": null,
  "time_start": 1664655627.661148,
  "_redirection": 5
}

Response

{
  "errors": {
    "http_request_failed": [
      "cURL error 7: Failed connect to luxroll.by:443; Operation now in progress"
    ]
  },
  "error_data": []
}

Any ideas?

This is what I see

% curl -i 'https://luxroll.by/wp-json/wp/v2/types/post?context=edit'
HTTP/2 401
date: Sat, 01 Oct 2022 21:13:59 GMT
content-type: application/json; charset=UTF-8
x-powered-by: PHP/8.1.6
cache-control: must-revalidate, max-age=0
cache-control: max-age=0
x-robots-tag: noindex
link: <https://luxroll.by/wp-json/>; rel="https://api.w.org/"
x-content-type-options: nosniff
access-control-expose-headers: X-WP-Total, X-WP-TotalPages, Link
access-control-allow-headers: Authorization, X-WP-Nonce, Content-Disposition, Content-MD5, Content-Type
allow: GET
vary: Origin
strict-transport-security: max-age=31536000
content-security-policy: upgrade-insecure-requests
x-xss-protection: 0
referrer-policy: strict-origin-when-cross-origin
x-frame-options: SAMEORIGIN
permissions-policy:
expires: Sat, 01 Oct 2022 21:13:59 GMT
cf-cache-status: EXPIRED
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=ziSzxZpLcFVOLagPlNezTE8LdBBCTpeBZioaIjBSi5egNJo%2FTtdXsTKwZqkO%2BpJ0SNn6RtXm8vJv%2B6UAP2Bx1ttLJAk3R4EHUtYOvYBlXfiCyLGkULL9%2BKxf8QSahiK%2BRq9OqGeU3mQM"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 7538348b2eb117cb-MEL
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400

{"code":"rest_forbidden_context","message":"\u0418\u0437\u0432\u0438\u043d\u0438\u0442\u0435, \u0432\u0430\u043c \u043d\u0435 \u0440\u0430\u0437\u0440\u0435\u0448\u0435\u043d\u043e \u0440\u0435\u0434\u0430\u043a\u0442\u0438\u0440\u043e\u0432\u0430\u0442\u044c \u0437\u0430\u043f\u0438\u0441\u0438 \u044d\u0442\u043e\u0433\u043e \u0442\u0438\u043f\u0430.","data":{"status":401}}

The message says:

“Извините, вам не разрешено редактировать записи этого типа.”

which apparently translates as

“Sorry, you are not allowed to edit this post type.”

when proxying is disabled, accessing oneself from the server goes without problems:

[[email protected] ~]# curl -Il luxroll.by
HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Sun, 02 Oct 2022 12:47:48 GMT
Content-Type: text/html
Content-Length: 162
Connection: keep-alive
Location: https://luxroll.by:443/

When you enable proxying, you get an error:

[[email protected] ~]# curl -Il luxroll.by
curl: (7) Failed connect to luxroll.by:80; Operation now in progress

I don’t see the same thing.

% curl -Il luxroll.by
HTTP/1.1 301 Moved Permanently
Date: Sun, 02 Oct 2022 20:45:09 GMT
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Sun, 02 Oct 2022 21:45:09 GMT
Location: https://luxroll.by/
Report-To: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=LwhkK7GmlbiHr2WJHWf8jyYch1upYotRM0iwEJ7qnd8H%2B%2FS8omCRauOmdlZb4tp1SOHFGNHqZ%2Bmd0tnyoA%2B%2BWxArOOiC%2Bba3thq3W9BZcP14BcytoLALuHitl74PGBx8xaDjnG8xl2lZ"}],"group":"cf-nel","max_age":604800}
NEL: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server: cloudflare
CF-RAY: 754047b42ae25a61-MEL
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400

I expect proxying is enabled as it clearly shows Server: cloudflare

Perhaps it’s your computer.

1 Like

Besides a curl error what problem do you actually have?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.