cURL error 28: Resolving timed out after 2000 milliseconds

Hello, im getting the below error on my site:

The firewall of your server is blocking outbound calls. Please contact your hosting provider to fix this issue. cURL error 28: Resolving timed out after 2000 milliseconds.

I have contacted my hosting provider (GoDaddy) and they are saying its the Cloudflare firewall.

Please can you advise if Cloudflare could be causing this issue?

Kind Regards

Kim

Your server does not initiate outbound traffic through Cloudflare.

Judging from that error, it’s a DNS error “Resolving timed out…” Have you checked with the MonsterInsights as to what it’s trying to do here?

Internet search is also helpful:
https://duckduckgo.com/?q=curl+error+28

Thanks for your message. I have actually Google searched this quite extensively. Sorry my previous message was quite vague. All recommendations say that its an error on the host end (ie GoDaddy), but they are saying nothing is wrong on their end and that the issue relates to a firewall with Cloudflare. I’ve ensured im running latest PHP and latest cURL on the server.

As far as I can tell I have not enabled the firewall with cloudflare. Ive attached screenshots of my settings in Cloudflare.

Next screenshot

Final screenshot

They’re very good at doing that, but I’m quite confident it’s an outbound communications error.

Thanks for your reply. Yes I checked with Monsterinsights they firmly believe it is a GoDaddy issue. See reply below:

“This is likely some software with the hosting that may need to be updated.
You’d need to contact their hosting provider and have them run a test on the curl version installed in the server, to make sure it can make outbound calls.
If you’ll need anything else, please don’t hesitate to reach us back anytime”

When checking with Godaddy as to why these errors may be happening, using this article as guidance (https://docs.presscustomizr.com/article/326-how-to-fix-a-curl-error-28-connection-timed-out-in-wordpress), I upgraded my PHP version, increased Server Memory Limit, They tell me that there is no firewall or security modules that are blocking outgoing cURL requests, and they say there is no limit on wp-cron and that loopback is not disabled.

Second Issue - (and it may be related) is that when I try and update a plugin / theme etc, the site just hangs, then it goes down. Eventually displaying a Cloudflare error 524 that says the site is unreachable. (see screenshot 2).

When I check my Cpanel, I see in the statistics page that the I/O usage is 74% and when looking at the CPU and concurrent connection usage page, it tell me that “Your site has been limited within the past 24 hours”.

I really think this is a GoDaddy issue, but they are swearing it is not them.

Very frustrating as i’ve never had this many issue with a hosting provider before. Very close to moving away from Godaddy.

As a final check, use the Overview page in the Cloudflare Dashboard and click the “Pause Cloudflare on Site” link in the lower right corner. This will put your site into DNS-Only, but wait 5 minutes for it to take effect. Then try the plugin again.

This topic was automatically closed after 30 days. New replies are no longer allowed.