Curl command doesn't work with subdomain

Hello, I am using GCP and Cyberpanel.
Whenever I try on terminal curl mydomain.com it works perfectly well.
However, when I try subdomain.mydomain.com it is not responding.
In my cloudflare account, I have pointed the same ip for the subdomain as the main domain has. Could you please help me to resolve the issue?

Without the actual hostname, or the exact error you’re seeing, I’m afraid we can not offer any specific suggestions.

An actual domain is engoory dot com and the subdomain is sms dot engoory dot com

‘curl’ to the subdomain redirects to https and /install in the subdomain, which that doesn’t exist (404).

It’s also interesting that the domain doesn’t resolve to IPv6 addresses. Did you disable these intentionally?

I am using Cyberpanel with Litespeed and added this subdomain website as a website, not as subdomain in Cyberpanel it is called “Child domain”. I have not disabled anything intentionally, I don’t know neither why it is rediricting to /install folder.
My .htaccess file shows me the following content from sms dot engoory dot com

Options -MultiViews
RewriteEngine On

RewriteCond %{HTTP:Authorization} ^(.*)
RewriteRule ^(.*) - [E=HTTP_AUTHORIZATION:%1]

RewriteCond %{REQUEST_FILENAME} -d [OR]
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule ^ ^$1 [N]

RewriteCond %{REQUEST_URI} (\.\w+$) [NC]
RewriteRule ^(.*)$ public/$1 

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ server.php

<Files ~ "^.*\.([Ee][Nn][Vv])">
 order allow,deny
 deny from all
 satisfy all
</Files>

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.