Curl Api shows Please wait while your request is being verified

as you can see i have those settings
i think same problem like here
my app trying to access my server from other servers in the api url using curl
but the api instead of showing data it shows Cloudflare validation
1 random server is here
1 working random server is here

so the conclusion is that Cloudflare try to validate my curl request on SOME servers not all.

what i tried is making a page rule like this

by searching more i found the topic i already mentioned so i tried the WAF rule
i came with this so far after i played with it a little
and now started seeing some events that the actions are bypassed when i try from the 2 servers i mention but the result remains the same why?

some other things might be usefull i have bot fight off, full strict ssl.

i am using Cloudflare for many many years but its first time i stuck on something like this (usually i just set attack mode off and everything was solved)
i am willing to make tests because i strongly need to solve this issue.

NOTE: problematic server is on hostinger or ovh, those values beign are showing on the events.

thank you for your time



Not really. That message is not from Cloudflare, but it was likely cached by Cloudflare. The message is from Imunify360 (Webshield), a firewall products that several hosting providers are using. You should talk to your hosting provider about whether they will allow you to adjust this firewall, or remove it. Lowering your Cloudflare security settings won’t have any effect on this issue.

For more details, please see this reply to an user that was facing a similar issue (origin server firewall message cached by Cloudflare).

thank you for this answer.
i will mark this as solved, because hosting has this forced to be enabled.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.