CSS minify not working?



Before I use Cloudfare I had w3 total cache and a basic CDN on OVH. I choice a pro plan for my website snapcoquin.fr, I have 10K unique visitors per day.

On Gtmetrix I had : A 90% B 80 % .

So I go to Cloudfare to boost my website speed and I turn off Minify on W3 total cache because Cloudfare had minify ( and when I turn off W3 total cache and Cloufare cace my images and videos doesn’t load).

But now , I have 79% A and 73% on gtmetrix

I have 30 on Minify JavaScript and CSS (Before Cloudfare I had 100 … ) https://gtmetrix.com/reports/snapcoquin.fr/yXKWGDLj


These files arn’t minify but when I have R3 total cache everything was minified.

That’s normal? or may be for my website I doesn’t need Coudfare and R3 total cache is better?

Thanks a lot and sorry for my basic english :slight_smile:


Minify operates on cached content and it looks to me like your origin is setting cookies when returning static content, for example on https://www.snapcoquin.fr/wp-content/themes/flymag/js/slider-init.js I see this in the response headers:

set-cookie: 300gp=R588051294; path=/; expires=Sun, 17-Jun-2018 09:18:19 GMT

If you can configure your origin to not send that cookie that will be best. Otherwise you can create a page rule such as https://www.snapcoquin.fr/*.js and set Cache Level to “Cache Everything” and choose an Edge Cache TTL to force us to cache. You can of course create another rule for other content such as CSS if they have the same issue with origin cookies.

Once the items are in the cache they will be minified by us.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.