Cron won't run on server

Has anyone figured out the fix for these? I’ve searched here, the Net and under my bed with no luck.

Whitelisted CF’s IPs on server. Added server’s public IP address to CF’s Firewall rule.
Disabled caching at CF.
Nada.

Thank-you

Cron is not exactly Cloudflare related. If the job doesnt run at all you need to check this on your server.

If the job runs, the title is not exactly accurate and if it fails because you run an HTTP request against your own server, that could fail because of the Cloudflare layer, however in this case the fundamental issue is not so much the failing call, but rather that you execute a local function via HTTP.

You better change your approach in this case and make that call without HTTP.

One workaround I’ve done for self-HTTP calls is to add the host’s IP address to /etc/hosts, so the HTTP request doesn’t route through Cloudflare.

That is certainly an option, but still just a workaround. All these HTTP calls for running something locally are just bad implementations.

1 Like

Yes, I understand that it no a CF issue, but it worked prior to moving to CF, so I was hoping that someone else had had this issue and knew what to do.

my cron is: /usr/bin/curl --silent https://mydomain.com/?pull-feeds=xxxblahblah

I’ve tried it with http://… as well

I’m using really-simple-ssl WP plugin, which creates:

RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

in .htaccess

I will give that a try. Thank-you.

The best suggestion would be probably to scrap that entire curl approach and run whatever you are running with it locally. That would also avoid any issues of that sort by definition.

1 Like

Above my pay grade, but I will forward that info to server tech. Thank-you.

This topic was automatically closed after 14 days. New replies are no longer allowed.