Creating page rules for multiple subdomains

Hi there, I am running a summit and need to give each of my 28 speakers their own link (subdomain). I have created new CNAME records for each of them.

I followed the instructions to create a page rule like this:
URL: subdomain followed by /*
setting: forwarding URL
Status: 301
Destination: https :// holly.kienoconference .com /$1

All worked perfectly.

Then I came to do it for my second speaker (and subdomain) and I get an error :

“your zone already has an existing page rule with that URL”

How do I set it up so the rule works for all my subdomains?

So grateful for any help. I can follow instructions but have zero knowledge in this area at all!

That doesn’t sound right. Can you please post a screenshot of all of your Page Rules?


Thanks for your reply. I’ve attached a screenshot and I was trying to do this for the new rule (spaces just so it allows a link in this message):

URL: www. kieno conference .com /*
setting: forwarding
status: 301
destination: https:/ /speakerpage . kienoconference .com/$1

I assume you want www.kienoconference.com/holly/ to redirect to https://holly.kienoconference.com/?

You can’t do that with the rule you have since that rule will redirect…
www.kienoconference.com/holly to https://holly.kienoconference.com/holly and
www.kienoconference.com/jane to https://holly.kienoconference.com/jane
…as the $1 copies everything represented by * (and why you get an error when you try to create another rule as you are trying to redirect from the same URL to 2 places).

You would need to create a page rule redirect for each name…
www.kienoconference.com/holly/* to redirect to https://holly.kienoconference.com/$1
www.kienoconference.com/jane/* to redirect to https://jane.kienoconference.com/$1, etc

If there’s a lot of names, you can do what you were doing with a dynamic redirect rule, but that takes some string manipulation coding skills. A bulk redirect may be easier…

1 Like

Thanks so much for taking the time to reply.
Oh gosh, I’m quite confused I think!

I’m not looking to do anything with www. kieno conference . com /holly

The subdomain is holly. kieno conference .com so I was just following instructions given by searchie (where I’m using the subdomain) so that if someone instead types in www. they will get re-directed. It seems that “holly” takes the place of www. (screenshot attached).

It works fine for the holly subdomain (Ive tested it) but it doesn’t let me add any more.

I don’t know if this screenshot is helpful to explain? “searchie.support” is their subdomain example

I’m still a bit confused about what you want to do.

www.kienoconference.com can only redirect to one thing (which is why you get an error when adding another redirect from it), so you can redirect it to holly.kienoconference.com, but nothing else.

How does someone going to www.kienoconference.com specify which speaker they want (if that’s what you are trying to achieve?)

Ah ok, so no one will be going to www. kieno conference .com
Instead I have created subdomains for each speaker at my event for example:

holly. kienoconference. com
miranda . kienoconference .com
rob . kienoconference .com

I created all of these in cloudlfare and have added them to individual registration pages in searchie, So each speaker will have their own registration page with their name in as above. We will only be sharing these links and NOT www. kienoconference .com

That all works fine.

The problem (according to searchie), is that because of the way it is configured, the name (e.g. holly) replaces the “www.”. So if someone types in www. holly. kienoconference . com it needs to be re-directed to https:// holly. kienoconference .com in order to work

That’s why they give the instructions to create the rule in cloudflare, but then cloudlfare wont let me do this for more than one subdomain

In which case, having www.kienoconference.com redirect to holly.kienoconference.com ensures www never reaches the host, which I think is good enough.

I think people using www.holly.kienoconference.com would be rare (some browsers may try it if 'holly.kienoconference.com` doesn’t resolve, but you’ve set it up so shouldn’t be an issue).

If you do want redirects for it, and all the other names, the main issue you would have is that these (www.name) would be a second level subdomain which isn’t supported by the default universal SSL certificate on Cloudflare. You would need to buy the Advanced Certificate Manager to handle those.

But ultimately, I don’t think you need to redirect www.name - the instructions from the host relate to making the domain resolve for the www subdomain wherease what you are trying to do is the opposite - point it at something else as you aren’t using it.

Thank you so much, that’s very reassuring re the second point. It sounds like I can just leave that alone then.

For the first point I’m guessing I can leave that too? So If someone types in www. kieno conference .com it will redirect to holly’s page alone and I dont need to worry about all the other pages. I think that’s what i currently have set up according to the rule?

Thank you so much for your help, I really appreciate it

You should probably also redirect kienoconference.com as well as www.kienoconference.com with another rule. (Make sure there is a proxied DNS entry for @ pointing to A 192.0.2.1 or AAAA 100:: as a dummy record).

Make sure you create CNAMEs or whatever you need for the other names in the DNS. I tried a few of the names on your page and they don’t resolve.

Ah yeah, the pages wont be working right now as we had to add something to them, so they are temporarily disabled.

For re-directing kienoconference .com - I just tried to do that but another error (screenshot). Im guessing it’s because I used the same rule as before, I have no idea what another rule would look like ( was just following instructions when I set up the first one :rofl: )

For this >> “make sure there is a proxied DNS entry for @ pointing to A 192.0.2.1 or AAAA 100:: as a dummy record).”

Ive gone to DNS, then “A” but I’m not sure what I have to type into these boxes:
Name required (Use @ for root)
IPv4 address (required)

kienoconference.com should be kienoconference.com/*

(the * copies anything after the domain name to $1 in the redirect).

1 Like

I see one issue, and one suggestion:

  1. www. holly. kienoconference . com is going to run into this issue:

https://developers.cloudflare.com/ssl/troubleshooting/version-cipher-mismatch/#multi-level-subdomains

  1. Not to try to add confusion to this, but you may want to use a Bulk Redirect list, instead. Subpath Matching = True will act like the wildcard at the end of your match. Preserve Path Prefix will act like the $1 in the target.

Hi there,

Thanks for your reply. I’m not using www. holly . kienoconference .com, but instead just holly. kieno conference. com so according to the page that you shared and also the instructions on the site I’m using, that should be ok?

For the second bit I might have to post on upwork to get someone to do this for me, as even looking at the link you provided I can’t make sense of that at all - definitely not my field of genius!

I just copied it from your earlier comment:

But if that’s not a concern, you can ignore my Point #1.

If Page Rules are working for you, then stick with it. However, if you run out, you could resort to Redirect Rules and/or Bulk Redirects.

1 Like

Thanks so much!

1 Like