Created an Origin Certificate and everything went kaflooey

ssl

#1

I’m having a web developer redesign my web site. Everything was going fine until today. I pulled up the site in the morning and saw the dreaded “internal server error” message. The only change that I made the night before was to create an “Origin Certificate” on Cloudflare. This generated code for a key and a certificate that I was supposed to copy and paste into files on my web host. I realized I was out of my league and did nothing at this point (I did NOT create files on my web host). When I saw that the site was broken I revoked the Origin Certificate hoping that everything would go back to normal. It has not.

I’m wondering if this chain of events caused the server error or if it may be something else. Any thoughts on my stupidity (and possible remedies) are welcome!

Thank you.


#2

Hi there. Are you receiving an error message generated by Cloudflare, or something from the webserver itself (Apache/NGINX)?

What SSL method do you have selected here on the Crypto tab?

If you need uptime immediately, you can pause Cloudflare by navigating to the DNS tab, and clicking on the orange clouds :orange: so they turn grey :grey:


#3

Andy,

Thanks for the reply. Here’s the message I’m getting from my webserver (Apache):

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

The SSL method that I have selected is “Full (strict)”.

I tried clicking on the orange clouds but this didn’t do anything.


#4

This should disable Cloudflare and any associated SSL settings. If you’ve done this and cleared your cache and the issue persists, then the issue lies with your origin server and not Cloudflare side. One last thing to try is setting the SSL mode to ‘Flexible’, though since the error is coming from Apache I’m inclined to believe it’s something with Apache and not Cloudflare settings.


#5

Andy, the problem was on my server and not with Cloudflare. Your comments helped a lot. Thank you.


#6

Glad you got it sorted. Happy to help! :grinning: