Created 3 subdomain A records on CloudFlare, only 1 works as expected

I created 3 subdomain A records pointing to the same domain. All records point to the same IP address:

The first added record works as expected - I can ping it and when go to it with the browser I get the correct response.

Second and third records didn’t work. The second and third records and are pointing to an unknown IP address, probably a Cloudflare proxy server?!

When I try them on the browser, It gives me page not working. It is not resolving to the correct IP.
Is there something else I need to do? It’s been about 1 hour but no luck. Will this be updated after a few hours? Or, is there a step I missed?

If the hostname (DNS record) is proxied and set to :orange:, yes it is proxied via Cloudflare and should resolve to the Cloudflare IP.

May I ask what is the error number?
Can you share a screenshot of this error?

Were your sub-domains secured with the SSL certificate before moving/adding them to Cloudflare and have you got valid and installed SSL certificate covering them?

Have you tried using a different Web browser, or a Private mode (Incognito)?
Maybe mobile data (4G LTE, cellular data) if anything different?

  • if it could be due to the DNS propagation / cache …

Here is the error:

The strange thing is the 3 A records were entered in exact same way. 1 works 2 don’t

I tried edge and tried incognito on chrome. tried another computer.
Its a mystery to me. I really want to use Cloudflare.

could this be because of the old A records? I deleted the old records from directnic a couple hours ago.

Thank you for feedback.

Unfortunately, I can reproduce it too at my end.

Seems like those 2 sub-domains didn’t yet got/generated an SSL certificate at your origin host/server, or if you are using cPanel then it’s not generated (via AutoSSL).
If so, make sure both sub-domains are temporary unproxied and set to :grey: (DNS-only).
Wait for a few minutes, then generate an SSL certificate for them.
After you confirm they are working fine over the secured HTTPS connection, switch back to proxied and :orange:.
Set SSL/TLS to Full (Strict) SSL at Cloudflare.

From the screenshot you’ve posted, ERR_TOO_MANY_REDIRECTS indicates to me like you are either:

  1. Redirecting HTTP to HTTPS at your origin host/server
  2. Not having an valid and installed SSL certificate for this sub-domain
  3. Wrong SSL option is selected under the SSL/TLS tab of Cloudflare dashboard → is it on Flexible SSL?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

I’m working directly on the servers. No cpanel.

my SSL certificates are up to date with certbot.
SSL setting on Cloudflare are set to flexible.

before I switched my name servers and DNS records from directnic to Cloudflare, everything was working as expected.

Is certbot certificates the problem? should I delete certbot certificates ? before following your instructions?

Great! :+1:

Can you switch to Full (Strict) SSL and re-check a minute-two later for any changes?

There is no need to do it if you have valid and installed certbot (Let’s Encrpyt) SSL certificate for your sub-domains at your server.

1 Like


All right that was it. It is working now. I didn’t understand the SSL settings.

Thanks for your help

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.